• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 638
  • Last Modified:

SQL Agent Job 2008 and SSIS issue

I created a SSIS package in BIDS2008, created a job in sql server agent 2008 that calls the Package.
However I'm getting this error.. I also cretated credentials and a proxy.

Unable to start execution of step 1 (reason: Error authenticating proxy domain\svc_SqlDev, system error: Logon failure: unknown user name or bad password.).  The step failed.

Any ideas what this could be?
Thanks,
0
TSG954
Asked:
TSG954
  • 7
  • 7
1 Solution
 
lcohanDatabase AnalystCommented:
Is the Package stored as a File or inside SQL Server?

As the package is executed by the SQL Agent asunder the proxy account, does that  user  "domain\svc_SqlDev" have all requred DB rights in SQL?
0
 
TSG954Author Commented:
The package is stored as a file.
What rights would be required for the domain\svc_SqlDev?
Thanks,
0
 
lcohanDatabase AnalystCommented:
http://msdn.microsoft.com/en-us/library/ms189064.aspx

"Before SQL Server Agent runs a job step that uses a proxy, SQL Server Agent impersonates the credentials defined in the proxy, and then runs the job step by using that security context."
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 
TSG954Author Commented:
Right, I created a credential for it.
0
 
lcohanDatabase AnalystCommented:
therefor you would need to grant sufficient rights on that account to perform whatever the package steps need to do.
0
 
TSG954Author Commented:
This is what I had done. I created a user domain\svc_SqlDev in Active Directory.
Then, I created a Credential called SSISProxyCredentials and in the Identity put "domain\svc_SqlDev", and the password the same
I had given to that account.
Where am I going wrong?
0
 
lcohanDatabase AnalystCommented:
You need to open SSMS and check that the account exists in SQL server under the Security - Logins and that it has sufficient rights against whatever DB objects the package steps need to perform.
0
 
TSG954Author Commented:
I checked the Logins in Security and there is an account. My package dosnt connect to any db right now since i'm just in testing mode.
0
 
lcohanDatabase AnalystCommented:
OK, do you have a password for the account?
If not you need to set a password for the Credential that is associated with the proxy. To do this, right click on the credential and select properties. Enter and confirm the password for the account.
0
 
TSG954Author Commented:
Yes, I have done this.
0
 
lcohanDatabase AnalystCommented:
Hm......
Because the package is stored as a file, can you navigate to that folder, double click the DTSX package and try to Execute it?
0
 
lcohanDatabase AnalystCommented:
So the proxy is "Active to the following subsystems:" - "SQL Server Integration Server Packages"
AND the job step where you execute the DTSX file is set to "Run as" the proxy account right?
0
 
TSG954Author Commented:
The proxy is set to "Active to the following subsystems:" AND the job step is set to "Run as" the proxy account right, correct.
As it turns out, I didnt need the proxy after all. I'm now running it as  SQL server Agent service account and its working.
I went the proxy route because I was getting an XML error before, which turned out to be that I was running the package from a different version,
i needed to place it in C:\Program Files (x86)\Microsoft SQL Server\100\DTS as as opposse to C:\Program Files\Microsoft SQL Server\100\DTS.

Thanks,
0
 
TSG954Author Commented:
Switched methods and worked fine
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

  • 7
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now