Exchange 2003 redirect http and https

Need help with a redirect. I have followed kb839357 article with no luck. I have gone over it and over it, but still get a login when trying the redirect with http://servername/exchange. I try to log in and can't, I endup with a Access Denied error. Just a reminder that owa works just fine using https://servername/exchange, I just can't get the forward to work correctly.

Here is what I have for the owahttps.asp page:

 <%

If Request.ServerVariables("HTTPS")  = "off" Then
                                    Response.Redirect "https://" & Request.ServerVariables("HTTP_HOST") & "/Exchange"
End If

      %>

All the help I could would be great..
LeonardArellanoAsked:
Who is Participating?
 
ckeshavSr. Infrastructure SpecialistCommented:
Cross check the permissions on the folder where owahttps.asp is located
0
 
ckeshavSr. Infrastructure SpecialistCommented:
0
 
LeonardArellanoAuthor Commented:
I just complete that, which is the same instructions as what Microsoft recommends, with different name and a little different code. Once everything is complete I get a login window, which I can not log into. I try three times and show a message of access denied.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
ckeshavSr. Infrastructure SpecialistCommented:
Does the credentials work when you are only on HTTP?

Cross check the credentials of the ID you are using to login?
0
 
LeonardArellanoAuthor Commented:
If I go to https://mail.name.org/exchange, everything is fine. But when I go to http://mail.name.org/exchange it prompt me to login, I try three times and then errors with Access Denied.

If is almost like the CustomError Virutal is not accepting the enable anonymous access, which is where the owahttps.asp file is at. it is almost like the redirect takes place, but can not fully run becuase it is asking for permission. SHould I built in uername and password under the enabl Anonymous access?
0
 
LeonardArellanoAuthor Commented:
You are the man, Checked the permission on the folder and everyone had read, but on the file everyone did not have permission to read the file. Change the permission and everything is good to go.

One more thing, If you want me to open another question, so that you get the points I can...

The next problem I'm having is: I'm trying to redirect to the /exchange folder. On the default Website, on the Home Directory, I clicked "a redirection to a url: input in /exchange, but nothing happens. Any guess as to why...

Thank you for your help..
0
 
ckeshavSr. Infrastructure SpecialistCommented:
The KB article 839357 you initially referred has the process for even this

If you want to modify the IIS Default Web Site so that clients can access the OWA logon page by typing only http://<server name> instead of typing http://<server name>/exchange, follow these steps.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

   Start the Microsoft Management Console (MMC) IIS snap-in.
   Right-click Default Web Site, click Properties, and then click the Home Directory tab.
   Under When connecting to this resource, the content should come from, click A redirection to a URL.
   In the Redirect to box, type /exchange.
   Under The client will be sent to, click A directory below this one.
   Stop and start the Default Web Site.

http://support.microsoft.com/kb/839357
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.