[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

XenApp 6 pass through authentication

Posted on 2011-05-12
3
Medium Priority
?
79 Views
Last Modified: 2016-01-07
I am having issues getting pass through authentication to work in my Xenapp 6 environment.  Opening the web interface automatically uses the credentials of the logged on user, however, when trying to logon to the published desktop, it appears like it is working, desktop actually loads and can see the wallpaper, start menu, recyle bin, but none of the icons from my profile, and then I'm prompted for my credentials (see the screen shot for the logon box I'm getting).  The desktop is usable (I can click on the start menu, etc) but none of the icons for my profile are loaded and displayed until I enter my credentials.  

Aslo, I get pop up  in the notification area about the roaming profile service being unable to load my profile and that my previously saved local profile has been used.

I'm using the icaclient.adm to set Kerberos authentication and Local user name and password (enable pass through authentication) on the client machine.  The WI is set to use Kerberos and pass through authentication.  I've also tried without Kerberos, I still get a logon box this way, but it is the blue Windows 2008 logon screen and the desktop isn't displayed like it is when using Kerberos.

The WI and XA servers are trusted for delegation, I've also set 'Allow delegating default credentials' in GP and added all my servers to the list.

Anyone have any other ideas on getting this working?

  Login box after published desktop opens
0
Comment
Question by:Program_Poser
  • 2
3 Comments
 
LVL 11

Accepted Solution

by:
KrAzY earned 2000 total points
ID: 35759209
So... you login to the Publish Desktop ok (appears ok), but then after that you have issues as noted above?  It sounds like you are using a roaming profile, correct?  I read through your post kind of quick, but have your tried with a local profile to see if your same issue exists?  That might help narrow down your issue.
0
 
LVL 5

Author Comment

by:Program_Poser
ID: 35798997
Thanks for the response and sorry for the delay.  

After further testing, I have a few separate scenarios.  The issue highlighted above appears to be isolated to a single account.  Tested on multiple PC's, same thing.  Interestingly enough, using the same PC's, a test account works fine.  However, I have mixed results with other accounts, some work, some don't.  The ones that don't, are promted for credentials before the desktop is displayed.

Can't seem to find the correct combination to get pass through working reliably.
0
 
LVL 5

Author Closing Comment

by:Program_Poser
ID: 41402081
We ended up installing a newer version of XenApp and working out these issues, can't say for sure what the issue here was specifically.  I know it's been awhile, sorry about that.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
Citrix XenDesktop 7.6 Citrix Policies Graphics
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question