Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1076
  • Last Modified:

Assign a macro hotkey to paste format (using format painter) in MS Excel 2010

How do I do this in MS 2010? I saw the answer for MS 2003. But I am lost with all the new menus and different places to go in 2010?

I want to assign a macro hotkey to paste format (using format painter) in MS Excel 010
0
Scruples89
Asked:
Scruples89
  • 4
  • 3
2 Solutions
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Hello,

the keyboard shortcut Alt-E-S-T <enter> will paste just the format. No macro required.

cheers, teylyn
0
 
zorvek (Kevin Jones)ConsultantCommented:
Add these two macros to your workbook:

Public Sub PasteFormatting()
    Selection.PasteSpecial Paste:=xlPasteFormats
End Sub

Public Sub AssignMacroKey()
    Application.MacroOptions Macro:="PasteFormatting", ShortcutKey:="V"
End Sub

Run the second to assign the shortcut key CTRL+SHIFT+V to the first macro. To copy formatting, select the source formatting cell(s), press CTRL+C, select the destination cells, and press CTRL+SHIFT+V.

Not much easier than Teylyn's solution but it's one less key press and two less steps ;-)

Kevin
0
 
Scruples89Author Commented:
When I do a alt-E-S-T and <enter> it pastes the text in unicode format!
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Scruples89Author Commented:
Also, I am having a problem with the copy. I do a Ctrl C to copy. the cell has the flashing dashed line around it. Then there is a funny sound. Then the cell no longer has the funny dashed line around it. But I can still paste the text into the new cell. BUT I just want to format that cell not paste text. I do have Clipmate running in the background.
0
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
You need to copy a cell first, of course. And when you copy and paste between to workBOOKs, they need to be in the same Excel instance, otherwise no Paste Special operation will work. If you see the option to paste text in unicode format, then the Excel workbooks are not in the same instance of Excel. Close one workbook. Then in the session with the other workbook, use File > Open to open the second file. Now the Paste Special dialog will show the options to paste only formats, formulas, validation, etc.

cheers, teylyn
0
 
Scruples89Author Commented:
What does it mean to be in the same instance? I have two work books open and they are both inside the excel window.
0
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Two instances means that the Excel application is actually started twice, once for each workbook. If you can see both open files in

View > Switch Windows

then they are in the same instance. In this case, the Alt-E-S-T <enter> keyboard shortcut will paste just the format if you have just copied a cell and that cell is in the Windows clipboard.



0
 
Scruples89Author Commented:
thanks
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now