Exchange MAPI call 'OpenMsgStore' failed

Receiving the following error in the logs after a few hours of exchange being started:
Event Type:	Error
Event Source:	MSExchangeSA
Event Category:	MAPI Session 
Event ID:	9175
Date:		13/05/2011
Time:		08:32:32
User:		N/A
Computer:	SERVER01
Description:
The MAPI call 'OpenMsgStore' failed with the following error: 
The attempt to log on to the Microsoft Exchange Server computer has failed.
The MAPI provider failed.
Microsoft Exchange Server Information Store
ID no: 8004011d-0512-00000000 

For more information, click http://www.microsoft.com/contentredirect.asp.

Open in new window


(Exchange 2003, SBS2003)

I have restarted the Microsoft Exchange Information Store service, which fixes the problem for a short while but this is by no means a 'fix'. Any ideas on the cause?

Thanks,
UncleVirus
LVL 1
UncleVirusAsked:
Who is Participating?
 
AdamRobinsonConnect With a Mentor Commented:
I'd say you're shutting down because you've exceeded the size of the stores allowed.  Did you adjust the maximum size of your Information Store in the registry per the ole MS KB suggestions?
0
 
AdamRobinsonCommented:
Is this a problem that just began?  If not, have you tried checking that the permissions on the MDBDATA folder are correct?  

I agree with you regarding the stock MS answer of "start the information store" not being incredibly helpful.  :)
0
 
UncleVirusAuthor Commented:
This has just started happening - No changes to the system made what-so-ever. There are all sorts of weird email flow problems and has remained unresolved today...
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
UncleVirusAuthor Commented:
Also seeing this in the event viewer upon restarting services:
The Exchange store 'First Storage Group\Public Folder Store (SERVER01)' is limited to 18 GB. The current physical size of this database (the .edb file and the .stm file) is <1 GB. If the physical size of this database minus its logical free space exceeds the limit of 18 GB, the database will be dismounted on a regular basis. 

Open in new window

0
 
AdamRobinsonCommented:
0
 
UncleVirusAuthor Commented:
I've just clocked that - I'm in the process of updating to SP2 (No idea why it wasn't already...) so I can edit the registry and up the limit to 75GB!
0
 
AdamRobinsonCommented:
Excellent.  Good luck, and let us know how it goes!
0
 
UncleVirusAuthor Commented:
SP2 and upping the mailbox store limit worked fine. Thanks for your help Adam :-)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.