• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2132
  • Last Modified:

New Draytek 2830 Router - Intermittent Outlook Anywhere access to Exchange

I replaced an old router with a new Draytek 2830 Dual WAN router. Immediately remote users started complaining that their Outlook was coming up with the "Connection to Microsoft Exchange has been lost" messages - that disappear after a few seconds.

I've tried various things -
Changing the load balancing settings so that all traffic from the Exchange server goes through WAN1 on the router
Changing the load balancing settings so that all traffic from the Exchange server goes through WAN2 on the router
Changing the external address for the outlook anywhere clients so that it comes in through WAN2

I'm pretty confident that it's something to do with the router - we never had these problems before. Having a little look around I'm wondering whether it's something to do with packet size? But we're getting to a technical understanding that's possibly out of my league
0
tenetics
Asked:
tenetics
  • 7
  • 4
1 Solution
 
Craig BeckCommented:
Go back to basics and try the setup with just 1 WAN connection.  If that works, connect the other WAN connection and try again.
0
 
teneticsAuthor Commented:
OK - that's been done - no difference on either connection.
0
 
Craig BeckCommented:
When Outlook drops can you still ping from one site to the other?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
teneticsAuthor Commented:
Yes - ping times / responses are fine - using web access is also fine - just seems to be Outlook Anywhere
0
 
Craig BeckCommented:
What's the MTU on the router set to?
0
 
teneticsAuthor Commented:
Being a Draytek, the user manual is pretty useless but I found this in telnet - my guess is 1442?

> wan mtu stats
Static IP/DHCP (Max MSS: 1500)
PPPoE(Max MSS: 1492)
PPTP/L2TP(Max MSS: 1460)
% wan ppp_mss <MSS size: 1000 ~ 1500>
% Now: 1442
0
 
Craig BeckCommented:
Yes, 1442 is the MTU size.  That should be ok.  Try reducing it though and see if it helps, to say 1300.
0
 
teneticsAuthor Commented:
I'll give it a go and come back to you! Thanks!
0
 
teneticsAuthor Commented:
OK. So this has been done for both WAN connections - rebooted router

Unfortunately - no difference, however under WAN in Telnet my options are:
ppp_mru
mtu
mtu2
DF_check
disable
forward
status
modem
modem2
wimax
detect
vlan

Under ppp_mru for wan1 and wan2 the MTU is set to 1500 with a min of 1400 and a max of 1600 - should I change this too?

And would you mind explaining why we'd want to reduce the MTU size rather than increase it?

Thanks

Adam
0
 
teneticsAuthor Commented:
OK, so the solution here was to backup the settings, reflash the router and restore the same settings - no rhyme or reason as to why it didn't work.
0
 
teneticsAuthor Commented:
because I wrote it myself.... and it's not really a solution
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 7
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now