[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Virtual Server keeps shutting itself off

Posted on 2011-05-13
37
Medium Priority
?
1,644 Views
Last Modified: 2012-05-11
We have a virtual server that has continued to shut itself off periodically for the last week or so.  When I go into check the event viewer to see what the error is, it states "The Com+ Event System failed to create an instance of the subscriber", and the Event ID is 4356.  Is there anyway to correct this problem to prevent the virtual server from continually shutting itself down?

Thanks
0
Comment
Question by:mwtn35
  • 16
  • 9
  • 6
  • +2
37 Comments
 
LVL 40

Expert Comment

by:coolsport00
ID: 35753711
0
 
LVL 124
ID: 35753733
Do you mean it's actually shutsdown, and turns off?
0
 
LVL 124
ID: 35753764
Was this created or P2Ved?
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 

Author Comment

by:mwtn35
ID: 35753769
When I use the technet article, and type in comexp.msc on that virtual server, it says windows can't find the application.  Does that mean it's not installed?  Any suggestions on how to proceed next?
0
 
LVL 40

Expert Comment

by:coolsport00
ID: 35753782
What OS is it?
0
 

Author Comment

by:mwtn35
ID: 35753791
Yes it actually shuts completely down and I have to login to VMware Vsphere client to restart the virtual machine.
0
 
LVL 124
ID: 35753811
Windows Server 2008?
0
 
LVL 5

Expert Comment

by:ProtechCT
ID: 35753826
If you receive the below alert within your event viewer, you’ll find that the id relates to mobsync.exe

To resolve unregister mobsync by typing regsvr32 “%systemroot%\system32\mobsync.dll” /u within the run box and click ok

Event Type: Warning
Event Source: EventSystem
Event Category: Firing Agent
Event ID: 4100
Date: date
Time: time
User: N/A
Computer: computer name
Description: The COM+ Event System failed to create an instance of the subscriber {6295DF2D-35EE-11D1-8707-00C04FD93327}. CoCreateInstanceEx returned HRESULT 8000401A.

0
 

Author Comment

by:mwtn35
ID: 35753880
Windows Server 2003
0
 
LVL 124
ID: 35753901
Technet Article Applies To: Windows Server 2008
0
 

Author Comment

by:mwtn35
ID: 35753904
Source:Event System
Category:52
Type: Warning
Event ID:4356
User: N/A
Computer: XXXXXX

Description: The COM+ Event System failed to create an instance of the subscriber {6295DF2D-35EE-11D1-8707-00C04FD93327}. CoCreateInstanceEx returned HRESULT 8000401A.

0
 
LVL 40

Expert Comment

by:coolsport00
ID: 35753999
Is this a DC or a member server?
0
 

Author Comment

by:mwtn35
ID: 35754016
It's a member server
0
 

Author Comment

by:mwtn35
ID: 35754023
This server is a file and application server as well as print server.
0
 
LVL 28

Expert Comment

by:bgoering
ID: 35754087
You might try disabling power management features: http://support.microsoft.com/kb/324347
0
 

Author Comment

by:mwtn35
ID: 35754158
Power scheme is Always On
Turn off hard disks- Never
System Standby- Never

Under Advanced
- Prompt for password when computer resumes from standby is checked
- When I press the power button- Shutdown is selected

Hibernation is disabled.
0
 
LVL 40

Expert Comment

by:coolsport00
ID: 35754228
Ok, so in W2K3, the 'components' isn't a snap-in, like in 2K8 per sè. To get to the components, go to Start -> Programs -> Admin Tools -> Component Services. When the MMC opens, drill down the Component Services tree until you get to COM+ Applications. Check the properties of the specific App Component that may be causing the issue. Also, check your COM+ services in the services snap-in.

~coolsport00
0
 

Author Comment

by:mwtn35
ID: 35754324
Under Services COM+ Event System is set to Automatic and is started, and the COM+ System Applications is set to Manual and is started.

I've drilled down into the Component Services tree and I see nothing wrong under that app component unless I am missing something.
0
 

Author Comment

by:mwtn35
ID: 35776817
Any other ideas how to possibly fix this, still having the issue at least once a day, and normally it's happening in the middle of the night which is getting old for me. :)
0
 
LVL 40

Expert Comment

by:coolsport00
ID: 35777022
One question that comes to mind is do you know that event is the one causing your VM to reboot, or is that all that you noticed in your VM's Event Viewer? You may be pursuing a dead horse there. Outside of what I've provided, I don't have any other answers. Anything else that could potentially be causing the issue? Did you install some update recently that potentially could've triggered this?
0
 

Author Comment

by:mwtn35
ID: 35777052
I know that that is one of the events causing the issue, because it's always right around the time that I get a phone call saying that no one can print, I remote into the VMware box and the server is shut off and I have to turn it back on.  There are a couple of SQL Errors prior too, I can post those and see if that sheds any additional light on the problem.  And I personally have not installed any new updates on that server.
0
 
LVL 28

Expert Comment

by:bgoering
ID: 35777461
There are basically two ways (that I know of) that this could be happening.

1. Something in VMware is causing it. This could be someone opening the vSphere client, right clicking the vm, then selecting power off. It could be a script invoking the vSphere CLI or PowerCLI interfaces to initiate a power off of the vm. It could be some other program making a web service call to vCenter (or to the ESX(i) host to initiate a power off. In any event, if this is causing the problem you should be able to select the vm in the client, go to the Tasks & Events tab, and see if there are any Power Off Virtual Machine tasks recorded.

2. Something within the vm is causing it to power off. This is typically done via an ACPI call. To diagnose this consider replaceing the hal and kernel with non-ACPI drivers.  To do this open device manager (devmgmt.msc), expand the top Computer node. Typically you will see ACPI Uniprocessor PC or ACPI Multiprocessor PC - right click that select update driver. On the Wizard opening page select "No, not this time" for the question on whether to connect to Windows Update then click Next. Select "Install from a specific location (Advanced)" then click Next. Select "Don't search ..." then click Next. Select "MPS Multiprocessor PC" if you started with "ACPI Multiprocessor PC", or "Standard PC" if you started with "ACPI Uniprocessor PC" then click Next to complete the wizard. After you reboot ACPI functions will be disabled, and if something was calling ACPI to power down the vm the problem should be solved.

Hope this helps...
0
 
LVL 28

Expert Comment

by:bgoering
ID: 35777474
I guess a third possibility is some logging on and shuting down the PC - but there should be an event log message if that is the case.... So I didn't consider it.
0
 

Author Comment

by:mwtn35
ID: 35780880
Went to the virtual machine itself and looked under the tasks and events like you suggested and here's the error that is recorded when the server shuts itself off.

vcpu-0:ASSERT vmcore/vmm32/platform/common/platform.c:34 bugNr=17332
0
 
LVL 28

Accepted Solution

by:
bgoering earned 2000 total points
ID: 35781015
Well that helps -- look at the knowledge base article http://kb.vmware.com/kb/10213 for the resolution :)
0
 
LVL 28

Expert Comment

by:bgoering
ID: 35781039
I just noticed this resolution refers to an older ESX version. What version of ESX(i) or you running?

Even if it a new version I would still expect it to be NUMA related error.
0
 

Author Comment

by:mwtn35
ID: 35781133
It's ESX Server version 3.01 Build 32039..  Is that what you were looking for?
0
 
LVL 28

Expert Comment

by:bgoering
ID: 35781176
Yup, then the kb article I posted is applicable - follow the steps in the article:

Solution
To resolve this issue:

Check if you are using NUMA architecture. To check if you server is NUMA check for the existence of the /proc/vmware/NUMA/hardware file.
If this file does not exist your server is not NUMA.

In your ESX Server system's advanced configuration options, set the Numa.MonMigEnable value to 0.
To set the Numa.MonMigEnable  value to 0:

Choose the host in the VI Client Inventory.
  Click the Configuration tab.
  Click on the Advanced Options link in the Software box.
  A new dialog appears, enter 0 for Numa.MonMigEnable .

Note: You need to follow these steps for all of your NUMA capable ESX hosts


If steps 1 and 2 do not resolve the issue, add the following line to the .vmx file of the virtual machine:
memoverhead = 60

After you complete those steps the problem should be handled.
0
 

Author Comment

by:mwtn35
ID: 35781184
The Numa.MonMigEnable value was set to 1 in the advanced settings file, so I have changed it to 0 as they recommmended, so I will see what happens tonight. I appreciate your efforts and willingness to help me out on this!
0
 
LVL 124
ID: 35781242
@bgoering: good catch.

Hopefully this be the issue!
0
 
LVL 28

Expert Comment

by:bgoering
ID: 35781246
No problem, good luck

Did you check for the existence of the NUMA hardware file?
0
 

Author Comment

by:mwtn35
ID: 35781281
Well I was/am going to assume since there were multiple NUMA values set in the advanced settings page that there is, but I am going to go verify for sure.
0
 
LVL 28

Expert Comment

by:bgoering
ID: 35781658
What is the model of your server?
0
 
LVL 40

Expert Comment

by:coolsport00
ID: 35782393
ditto "bgoering"...I was all outta ideas! :)
0
 

Author Comment

by:mwtn35
ID: 35785196
Since I made the change to that configuration file last night change the NUMA .MonMigEnable from 1 to 0, the server has yet to shut itself off again.  I am going to monitor the rest of this week and I will keep you guys updated, in case there is another issue besides this one.  Again I appreciate the effort on this, and I would like to keep this open through the first of next week.  Thanks
0
 
LVL 28

Expert Comment

by:bgoering
ID: 35785203
Sounds good to me
0
 

Author Closing Comment

by:mwtn35
ID: 35815874
Great job on assessing my issue, so far this fix seems to be working quite nicely.   Thanks!
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If we need to check who deleted a Virtual Machine from our vCenter. Looking this task in logs can be painful and spend lot of time, so the best way to check this is in the vCenter DB. Just connect to vCenter DB(default DB should be VCDB and using…
When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
Teach the user how to edit .vmx files to add advanced configuration options Open vSphere Web Client: Edit Settings for a VM: Choose VM Options -> Advanced: Add Configuration Parameters:
Teach the user how to join ESXi hosts to Active Directory domains Open vSphere Client: Join ESXi host to AD domain: Verify ESXi computer account in AD: Configure permissions for domain user in ESXi: Test domain user login to ESXi host:
Suggested Courses

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question