Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cisco Port-Channel on Cisco 3550 switch showing as down

Posted on 2011-05-13
5
Medium Priority
?
2,110 Views
Last Modified: 2012-05-11
I have a Cisco 3550 Switch I configured with an etherchannel because I have teamed NICs on one of my 2 of my servers.    If I do a "show int port-channel1" it shows as down, and I don't know why.  I provided some information below.  Any assistance would be greatly appreciated.  Thanks.

Switch_SW2#show etherchannel
                Channel-group listing:
                ----------------------

Group: 1
----------
Group state = L2
Ports: 4   Maxports = 16
Port-channels: 1 Max Port-channels = 1
Protocol:   LACP
Minimum Links: 0

Group: 2
----------
Group state = L2
Ports: 4   Maxports = 16
Port-channels: 1 Max Port-channels = 1
Protocol:   LACP
Minimum Links: 0

Switch_SW2#show int port-channel1
Port-channel1 is down, line protocol is down (notconnect)
  Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)
  Description: SQL-SERVER-TEAMED-NICS
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 0/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed, media type is 10/100BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Switch_SW2#show int port-channel2
Port-channel2 is down, line protocol is down (notconnect)
  Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)
  Description: SQL-SERVER-TEAMED-NICS
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 0/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed, media type is 10/100BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Relevant configs

interface Port-channel1
 description SQL-SERVER-TEAMED-NICS
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 spanning-tree portfast
!
interface Port-channel2
 description SQL-SERVER-TEAMED-NICS
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 spanning-tree portfast

interface FastEthernet0/30
 description NIC1
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 channel-group 1 mode passive
!
interface FastEthernet0/31
 description NIC2
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 channel-group 1 mode passive
!
interface FastEthernet0/32
 description NIC3
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 channel-group 1 mode passive
!
interface FastEthernet0/33
 description NIC4
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 channel-group 1 mode passive
!
interface FastEthernet0/34
 description NIC1
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 channel-group 2 mode passive
!
interface FastEthernet0/35
 description NIC2
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 channel-group 2 mode passive
!
interface FastEthernet0/36
 description NIC3
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 channel-group 2 mode passive
!
interface FastEthernet0/37
 description NIC4
 switchport access vlan 40
 switchport mode access
 speed 100
 duplex full
 channel-group 2 mode passive
0
Comment
Question by:denver218
  • 3
5 Comments
 
LVL 47

Accepted Solution

by:
Craig Beck earned 2000 total points
ID: 35754048
Try setting channel-group to active instead of passive...

channel-group 1 mode active

Also, you have spanning-tree portfast on the Port-Channel..... remove that.  Port-Channel config should be the same as the ports that are members of the EtherChannel.
0
 
LVL 4

Author Comment

by:denver218
ID: 35754172
I just tried setting the channel-group to active and its still down.  I also removed spanning-tree portfast onthe port channel.  Any other ideas?
0
 
LVL 4

Author Comment

by:denver218
ID: 35754265
Do I have to have "switchport mode trunk" on my port?
0
 
LVL 4

Author Closing Comment

by:denver218
ID: 35754504
After making the changes you stated above the port-channel still didn't come up.  I did a little more research and found a link that said to do a shut and a no shut on the port-channel.  I did that and the port-channel came up.  Thanks.
0
 
LVL 14

Expert Comment

by:SIM50
ID: 35754574
You don't need to have switchport mode trunk, it should be switchport mode access.

Portfast command should be on physical interfaces, not on the ether channel. As a precaution also add "spanning-tree bpdu guard enable" so when when it receives bpdu, it will go into err-disabled state.
Also, check your NIC teaming options.
Check out this Cisco article about ether channel and NIC teaming: http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a008089a821.shtml
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
In this article, we’ll look at how to deploy ProxySQL.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question