allow user to ssh to esx host

Hi All,

we have a need to allow ssh into esx hosts. I don't want to share the root password with everyone, so can someone advise how to achiev this?

We are on vsphere 4.1

Thanks

fireburn11Asked:
Who is Participating?
 
Andrew Hancock (VMware vExpert / EE MVE^2)Connect With a Mentor VMware and Virtualization ConsultantCommented:
Here are a few pictures to show you the way:-

Connect to the ESX host using the vSphere GUI Client.

Select the host server

 Select Users and Groups
 Right Click in the white space and Click Add
Make sure when you create new Root users you add to the Root group.
userandgroups3.jpg
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Checkout this article

http://kb.vmware.com/kb/8375637
0
 
bgoeringCommented:
Create a local user on the host or integrate with active directory. Is this ESX or ESXi? Licensed or free version?
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
What access do you want to give the users at the console?
0
 
coolsport00Commented:
Simply log onto the host(s) directly, click the Users tab, rt-click in the whote space & select 'Add user'. There should be an option to allow SSH in the user properties.

Regards,
~coolsport00
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Do you just want to create additional "root" super users?
0
 
fireburn11Author Commented:
we are on esx4.1 , i want to create additional "root" super users.

Thanks
0
 
coolsport00Commented:
In the user properties, add the root permission..
0
 
fireburn11Author Commented:
Thansk Hanccocke,

where would I go to allow ssh for that user once I add the user to root group?

Thanks
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Do you already provide root access to ssh?
0
 
fireburn11Author Commented:
using root account to ssh is disabled.

Thanks
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.