Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 870
  • Last Modified:

Sharepoint 2010 Application Url not working in web Front End

1)I have installed Sharepoint 2010 in Farm. 1 web (virtual) and 1 application (virtual) and 1 db server (physical).
2) Upgraded an application from WSS 3.0
3) Sharepoint portal uses both Windows and Claims (FBA converted) Authentication.
4) I am able to access the site using windows/forms authentication from within application server, where as when I access from web front end, I get the error

The Web application at http://vmweb1:91 could not be found. Verify that you
have typed the URL correctly. If the URL should be serving existing content,
the system administrator may need to add a new request URL mapping to the
intended application.

I type http://vmweb1:91 on ie, this resolves to http://vmweb1:91/_login/default.aspx?........

but throws the above mentioned error.

Please help.
0
vasuwins
Asked:
vasuwins
  • 7
  • 6
1 Solution
 
GeorgeGerguesCommented:
did you extend the application correctly through Central admin after you finished the migration ??
0
 
vasuwinsAuthor Commented:
Do I need to Extend application for it to work from web server of that farm.

When I created the application I configured it for Claims-based and specified both Windows and Forms Authentication do I need to extend then also.

Also, I have another application on Port 81 (in the same farm). Home Page loads ok that application from web server (does not require Authentication) but inner pages throw the same error (again does not require authentication).

0
 
vasuwinsAuthor Commented:
when I type http://vmweb1:81/ it resolves and shows the http://vmweb1:81/boards/pages/home.html page but this is not the case for port 91

request for http://vmweb1:91 gets redirected to http://vmweb1:91/_login/default.aspx (it is default login page provided by sharepoint - no changes done).
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
GeorgeGerguesCommented:
If that is claims based application , then your application should work the same way on both servers but it should have the same name in the alternate access mapping section.

you may not be able to connect directly with the <servername>:port


0
 
vasuwinsAuthor Commented:
This is what I have tried, I have Enabled anonymous Access on web application http://vmapp1:91, now it is showing http://vmapp1:91/default.aspx. However, If I try to sign-in, it throws the error

The Web application at http://vmweb1:91 could not be found. Verify that you
have typed the URL correctly. If the URL should be serving existing content,
the system administrator may need to add a new request URL mapping to the
intended application.

This seems to be something related to Claims Authentication and related login page redirection.

Any Ideas?
0
 
GeorgeGerguesCommented:
no do not enable anonymous access on the application after configuration.


can you provide a list of the alternate access mapping for this application ?
0
 
vasuwinsAuthor Commented:
Just for testing only I have enable Anonymous access, I have disabled it

http://vmapp1:91 - Default - http://vmapp1:91
http://10.0.3.18:91 - Intranet - http://10.0.3.18:91

For now, I have not specified any thing for Internet Zone.
Though I need to do it later as a site.
0
 
GeorgeGerguesCommented:
You need to add alternate access mapping of
http://vmweb1:91

to your
http://vmapp11:91  application.


0
 
vasuwinsAuthor Commented:
Adding Alternate Access Mapping gives a page cannot be displayed.
0
 
GeorgeGerguesCommented:
can you publish a screen show of this

Central admin -> services on this farm
Services on Server

For each server

thanks
0
 
vasuwinsAuthor Commented:
Servers in Farm
Servers in Farm
services running on Application Server
services running on Application ServerServices running on web Server
 Services running on web Server
Services running on Database Server
Services running on Database Server
0
 
GeorgeGerguesCommented:
Are you sure the application at 91 or 81 is a SharePoint application not a standard web application . ?


Can you post a copy of your web application list from CA . manage applications

I think there might be a hard coded  redirection on your IIS or one of the page s.

0
 
vasuwinsAuthor Commented:
I resolved it like this,

I extended the application with Extranet, Added AAM entries for web front end and edited the Public urls to specify the web front end.

For Internal Urls I specified, both computername.domain.com:port and ipaddress:port. Then removed and upgraded the database once again. This resolved the issue
0
 
tshastryCommented:
Hi Vasu,

Can you please help me resolving this issue? I have the exact same issue as you. I set up everything fine looking into sharepointchick webpage and everything works fine on the server, but I am unable to access the FBA enabled webapp outside the server from any other machine. What is addingalternate access mapping means exactly, what should I do? Also what do you mean by removed and upgraded the database once again, how can you do this? Please help!

Regards,
tp
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now