Config webserver

ChuyenGia
ChuyenGia used Ask the Experts™
on
Hi all,

I have static IP, and I'm using Microsens modem. I want to config my webserver on my PC so that I config NAT to access to WebServer PC. But when I connect to static IP from the internet, the router page will be shown? How can I fix this problem?

Thanks a lot.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
There are two ways to fix this problem, move the management of your modem to HTTPS on port 443 or change the port of the website to something else such are 8080. Then when you try to access the website you will have to type (ipaddress):8080 for example: http://64.33.33.23:8080. The problem is the modem managment is setup on the same port as your website, port 80. The router takes precidence.
Or if there is a way to disable external managment of your modem that would work also.
Verify the IP address you are using for NAT is the ip address of the PC and not the default gateway.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

If u like more detailed information please provide the modem model.

When u want to run a webservice there are a few things u need to setup.
1. A webserver with a internal (non routeable static IP)
2. Your router and firewall to allow access to port 80 (so NAT from port 80 to the local static ip port 80)

I think the first step your u works correct. U can check this by opening the local ip from a other local box.

Now part two the router/Modem. This modem should NAT port 80. If a other service is running on port 80 of the remote IP it is not possible to run your website on it. A sollution for this would be to deny remote modem administration. This would make it possible to use port 80 for your website.

Off course your webserver should be able to connect to the internet else connecting from the internet to the server would also be impossible.

Author

Commented:
First, I use port 80 but it is not work so that I add port 8080 and it is not work too.
My configuration like image below. NAT
If u do on a other local machine in the webbrowser http://192.168.1.8:8080 u will see a page?

Note that localy testing (your remote ip) does not always work. So please check on a other internet connection or let a friend test it.

Author

Commented:
I can connect to http://192.168.1.8:8080 from local pc or other pc in LAN. But my friend in other network can't connect to http://myStaticIp (router page will be shown here)
are u sure ur are using the right remote IP. Check http://www.whatsmyip.org/. The other user has to use the IP shown on the page (note the IP can change depending on your provider). If ur ip is changing u can use a service like http://www.dyndns.com/
also try http://myStaticIp:8080
If ur routerpage is shown on your remote IP u have remote administration access (or similar) enabled. Please check the security tab.

Author

Commented:
It's work when i changed Server IP to my lan pc IP and removed remote host.
Thanks a lot.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial