Informix 9.4TC on Windows, physlog and logspace at 99% full, how ti clear or increase

ksquyres
ksquyres used Ask the Experts™
on
I have a Windows server 2003 with an IBM Informix Dynamic Server 9.40.TC7. New to the site but the situation is starting last week it will run for a while then odbc connections hang. A restart will usually bring it up for a while. It is running Misys software. Through their utilities I found that the physlog and logspace for the Informix instance are both 99% full. Suspect it's the problem. I know MS SQL but little about Informix. My understanding is that these are transaction logs and I would assume they would stay mostly clear. There are 10 users, moderate activity at most in a medical office. Off at night and weekends, but logs never change. I have been able to enable backups, that script uses ontape. and I now have access to command lines like onstat. It confirms physlog size 56320 free 72, and logspace size 153600 and free 547. How do I clear? Extend? I only need to buy about 6 weeks of use as a migration is underway.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
First, find your "onconfig" file, which is where most of Informix configurations are.
If you configured the server correctly, %INFORMIXDIR%\etc\%ONCONFIG% is the file.
Open it with a text editor, find the line that starts with "LTAPEDEV".
If you left it untouched, it would has "\\.\TAPE1" as its value. Delete it.(Or comment the whole line out.)
Restart the Informix server.

By doing this, you're turning off logical log backup, which means you do not have up-to-date (kind of real-time) backup. But you still have regular backups, if you made any.

Commented:
One more thing:

In onconfig file, find another line with MSGPATH. It has the full path & filename of the message log.
Look into the message log file. It tells you what's current wrong (probably saying something like "logical log full"), and during restart, confirms your configuration changes(like LTAPEDEV).

Author

Commented:
I did find the LTAPEDEV line. It currently goes to disk. This is a recent addition from earlier today though. There was a place in the Misys admin console to turn on log backups. It was previously disabled, I enabled it. Although I have not been able to get a successful backup since then. The system is generally responsive for a hour or so after reboot and I was waiting until close to day to try and fire off a backup with the loggin backup enabled. Would backing up the log file trigger it to clean up?
The msg log is full of this
17:03:21  listener-thread: err = -951: oserr = -951: errstr = informix: Incorrect password or user informix is not known on the database server.
 System error = -951.

There was a question of whether the informix user password was correct in all the places used and I thought I had found them all. Maybe not. The database is running under the informix user account.
I am clearing the log and reatarting.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
I saw the LOGFILES setting in onconfig, currectly at 51 and thats what onstat -l showed and they were full. Can I raise that and get some room?

Commented:
"responsive for a hour or so after reboot" - This is a typical symptom of logical log problem, and it shouldn't be happening if you turned it off (LTAPEDEV is null).

I'm not familiar with Misys, but I recommend you to entirely turn off the logical log backup. Because it gives you more problems than benefits if you don't know how to handle it properly, and your database is temporary and of low transaction after all.
Edit the onconfig file directly, and confirm the change by checking the message log during the restart of Informix since it's a possibility that you are editing a wrong file.

I don't think the error 951 is related. It seems a client program is trying to connect to your server with a wrong password. It's the problem of the client, and shouldn't be affecting the server.

Commented:
This LOGFILES parameter is used during disk initialization (restarting the server from scratch - without any existing database). It has no effect once you have a working database. You need to use onparams to add or drop log files.
Yes, if you increase the LOGFILES using onparams, it will give you a little more time, but the log will eventually fill up.
Why don't you just disable log backup?

Author

Commented:
I think I have been looking at "log backup" wrong. I was thinking that enabled meant it would be picked up when doing an ontape operation and that they would then clear. If I set LTAPEDEV null then it does not use the logfiles at all but writes transactions directly to the database. Is that correct? Is it ok then that logspace and physlog show 99% full? Is it just rotating logs rather than running out of log room?
Commented:
"Is it just rotating logs rather than running out of log room?"
Yes.
If you disable logical log backup, Informix server assumes that a log file is backed up as soon as it's filled up.
Don't worry about the physical log, it usually doesn't make problems.

Author

Commented:
That's what I'll do. Thanks for the prompt info. Everything is a rush you know.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial