How to enable outlook to open unknown files

Gabriel_Espinoza
Gabriel_Espinoza used Ask the Experts™
on
My company has a computer system that sends some .ASP files attached to the emails. I've seen other people opening those files straight from Outlook by double clicking them.

In my case, I try to double click the attached file but instead of opening the file, it shows a window to save the file in the PC.

How can I configure Outlook 2007 to open this file by making double click on it?

as a remark, once I save the file in Desktop, if I double click it, it opens the web-browser and shows the info with no problem.
I've been told that the file is HTML, but only the extension is ASP.

In advance, thank you very much!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Should be something like this. It's an old article but the premise is still the same. Associate your extension with a program via Windows Explorer

http://www.techtalkz.com/microsoft-outlook/189431-outlook-2002-prompt-you-save-open-attachment.html

1. Close Outlook.
2. Open Windows Explorer or ‘My Computer’ (or a similar window)
3. Click ‘Tools’ --> ‘Folder Options’
4. Select the ‘File Types’ tab
5. Locate the file extension the attachment uses and select it i.e. doc (Word documents), xls (Excel Spreadsheets), pdf (Adobe Acrobat Reader) etc.
6. Click ‘Advanced’
7. Uncheck or check (depending on desired result) the box that says "Confirm open after download"
8. Click OK, then OK again.
9. Close Windows Explorer/‘My Computer’ (or a similar window).
10. Open Outlook & try opening an attachment.

Commented:
.ASP file are blocked because they are consider Level 1 Attachment Security Risk.  You may need to modify your registry settings to resolve this issue.

Please to the following artilce for resolution:
http://support.microsoft.com/kb/926512/en-us


Good Luck!
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Author

Commented:
thank you all for the fast replies.

@Number-1: I don't have problem with that, once the file is saved, I can open it by making double click on it

@saastech: I will try the registry trick. I may have an answer the monday (friday is almost over here in Chile)

Thank you both :)

Author

Commented:
Hello again, after a good weekend, here I am with the reply :)

I tried the tips you gave me, saastech, with no luck. Those tips only allowed me to avoid the deletion of the attached files. I need the files to be open right from outlook.

Here's a picture of the message.
any other idea?

Outlook's Message
Open outlook then click tools then highlite macro,then choose security,here you can make the changes your looking for .
Make sure theres no checkmark  when you look in automatic download everything should be checked permit.
Now highlite e-mail security make sure allow script in public folders is checked.
Now highlite Attachment Handling make sure reply with changes is unchecked then click attachment and document previewers make sure all are checked.
What is macro security set to?

Author

Commented:
thank you for the reply, joinaunion

I tried what you say and the problem is still there.
In Ms Outlook 2003 I could open the ASP file right from the browser, in Outlook 2007 I can't.

here are some pictures of the configs:

 Automatic Download Macro Security Attachment Handling
Sorry I just realized that .asp files are blocked by default in outlook.Have the sender resend the file with a different extension,like .html .doc something along those lines.
Heres a list of blocked extensions.Thats why your getting error that its a virus.
http://office.microsoft.com/en-us/outlook-help/blocked-attachments-in-outlook-HA001229952.aspx
Most Valuable Expert 2011
Top Expert 2011
Commented:
It is a Level 1 attachment type....

Im curious to see what reg values you tried in the second post...

I would look at these three specifically..... The last one first............

Remove file name extensions that are blocked as Level 1 security items
This policy lists the file name extensions that are demoted to Level 2 security.

Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Outlook\Security
String: FileExtensionsRemoveLevel1
Values: List of file name extensions that are separated by a semicolon

And to remove the prompt to Save As (instead of just opening......)

Remove file name extensions that are blocked as Level 2 security items
This policy lists the file name extensions that are removed from Level 2 security.

Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Outlook\Security
String: FileExtensionsRemoveLevel2
Values: List of file name extensions that are separated by a semicolon

The Level1Remove registry entry
This policy lists the file name extensions that are demoted to Level 2 security.

Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Outlook\Security
String: Level1Remove
Values: List of file name extensions that are separated by a semicolon

Note If the DisallowAttachmentCustomization registry entry is present, Outlook 2007 ignores the Level1Remove registry entry.

Author

Commented:
Thank you,
This worked perfect ^^
Most Valuable Expert 2011
Top Expert 2011

Commented:
Which one?

Author

Commented:
I had to create a registry key with the 3 values,

here is the text of the registry:


Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Outlook\Security]
"FileExtensionsRemoveLevel1"=".asp"
"Level1Remove"=".asp"
"FileExtensionsRemoveLevel2"=".asp"
"AdminSecurityMode"=dword:00000003

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial