We help IT Professionals succeed at work.
Get Started

Unable to start VM - file locked?

hongedit
hongedit asked
on
7,867 Views
Last Modified: 2012-05-11
Hi

I am unable to start one of my machines after powering it off. Error:

Unable to access file [Datastore] SQL/SQL.vmdk since it is locked.

See the error stack for details on the cause of this problem.

Reason: Failed to lock the file.
Cannot open the disk '/vmfs/volumes/UUID/SQL.vmdk or one of the snapshot disks it depends on.

I tried to clone the VM, but the clone also fails to start with error that the file is not a valid virtual machine.

The Datastore is an iSCSI SAN.

Any ideas?
Comment
Watch Question
Top Expert 2010
Commented:
This problem has been solved!
Unlock 1 Answer and 36 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE