We help IT Professionals succeed at work.
Get Started

MSIEXEC Issue

622 Views
Last Modified: 2012-05-11
I wrote a logon script that works great except for the most important part, the application installation. Actually the application installs perfectly, however, it does not show up in Add/Remove Programs, but it is registered in the registry. For some reason if I run:

Msiexec.exe /qn /i "my.msi"

it installs but like I said, it does not show in Add/Remove Programs, but if I run with UI:

Msiexec.exe /i "my.msi"

it does show up in Add/Remove Programs.

The only thing that I can presume is that the actual msi package itself has been configured/constructed for this to occur, but I do not know why.

Should I use InstEd to break into the msi package and tweak it or what? I really need this application to show in Add/Remove Programs.




Comment
Watch Question
Commented:
This problem has been solved!
Unlock 1 Answer and 7 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE