oracle sql developer debugging

claghorn
claghorn used Ask the Experts™
on
I use oracle sql developer 3.0 to debug a procedure. I compile for debug, set my breakpoint on a line and click the debug button. It produces a pl/sql block for the procedure which can be used for the debugging output but it comments out the DBMS_OUTPUT.PUT_LINE parts. It calls this legacy code. Why does it comment this out? How do I prevent it from doing so? Where is the setting for this so I can turn it off?

DECLARE
  IN_VAR NUMBER;
  OUT_RESULT NUMBER;
BEGIN
  IN_VAR := NULL;

  OUTPUT_PROC.PROCESSORDER(
    IN_VAR => IN_VAR,
    OUT_RESULT => OUT_RESULT
  );
  /* Legacy output: 
DBMS_OUTPUT.PUT_LINE('OUT_RESULT = ' || OUT_RESULT);
*/ 
  :OUT_RESULT := OUT_RESULT;
END;

Open in new window

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2011

Commented:
- it is commented so that it won't display the output on script/dbms-output window unnecessarily each time you run the procedure. so you can delete out the comments "/* Legacy output:" and "*/". then run it during debugging purposes. apply the comment back when you have finish the debugging.

Author

Commented:
Yes I already gathered this much on it. But do you know how to prevent it from doing so? I want to see all output all the time. This is the purpose of debugging for me. I've seen other peoples sql developer (same version as mine) simply output everything as a default. ie: there is no commenting out what it calls legacy output. Do you know what preference setting would turn this commenting off?
Top Expert 2011
Commented:
- i can see that you've also open the same question on OTN.
- i've downloaded the latest sql developer 3.0 and try to simulate your pl/sql debugging step. however i didnt get the DBMS_OUTPUT automatically as you do. in the preferences especially on >code editor and debugger options does not have any option on this.
- i would suggest, uncomment any DBMS_OUTPUT that you need to be permanent displaying the output. or does it re-comment back the DBMS_OUTPUT whenever you run the procedure?
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
I've face the same problem. Once I've uncomment that part, then it was working properly. It never commented automatically later on.

Author

Commented:
Yes I did post the question on OTN. I would delete it if I could. I would still seek to reward the points to you guys for your efforts on Experts Exchange.
I did also see myself that once uncommented it remains as such. I guess its the best I can do. A pain but at least it remembers.
Top Expert 2011

Commented:
- i believe thats the only way for now, uncomment manually. i've look around and there is no documented on uncommented debugging options in the documentation.
- let the question run on OTN too, as sometimes Oracle technical do respond to the questions there.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial