USB Thumb Drive Won't Do HFS+ Format

markbyrn
markbyrn used Ask the Experts™
on
I've been trying to format a 128 GB USB thumb drive as a Mac OS Extended volume (HFS+) but it silently fails and the only successful format I can do is MS-DOS FAT. As I want to use the drive to install a dev version of Lion, I need the HFS+ format and trying it in terminal gave the following result:

Marks-MacBook-Pro:~ markbyrn$ diskutil eraseDisk HFS+ lion disk1
Started erase on disk1
Unmounting disk
Creating the partition map
Waiting for the disks to reappear
Formatting disk1s2 as Mac OS Extended with name lion
Initialized /dev/rdisk1s2 as a 128 GB HFS Plus volume
Mounting disk
Could not mount disk1s2 with name (null) after erase
Finished erase on disk1
Marks-MacBook-Pro:~ markbyrn$

So it appears to initialize but won't mount. I also tried partioning the drive into 2 or 4 partitions and formatting an individual partition but that didn't work either.

I have installed the dev version (preview 2) of Lion on a 16 GB thumb drive but there's not enough free space to do an update to preview 3. Any advice on how I can get this 128 GB thumb drive formatted?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Have you tried using Disk Utility to format it or only Terminal. If not, try Disk Utility.

Some thumbdrives actually have to drives in them, one of which, usually a small one, has some proprietary software on it and is read-only. I wonder if you are trying to format the wrong drive?

Author

Commented:
No, I tried Disk Utility first before I used the Terminal command - fails just the same except the terminal command gave a tiny bit of information instead of the silent failure from Disk Utility.  Perhaps you're on to something with the two drives but Disk Utility didn't show more than one, and I was able to successfully format the drive using the MAC Disk Utility with the MS-DOS FAT option.  Than I tried formatting with the HFS+ option and it still didn't work.  From what I gathered in using the terminal command, it seems that it successfully formats for MAC OS but won't mount after it does.  
It doesn't seem to recognize the name. You are trying to format it as "lion" from the looks of it, but it says it can't mount "null".

Try Disk Utility again, using a different name, and afterward check the console logs.
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Author

Commented:
Tried using a different name and untitled - no joy.    
Try clicking on the Partition tab. Set it to one partition and set the partition Map to GUID

Author

Commented:
Strung, I already tried your suggestion to set one partition with GUID - didn't work.  

As an added background, the thumb drive is a Kingston DataTraveler 200 USB flash drive and it does not appear to have U3 protection (ran a U3 removal tool and nothing detected) but perhaps it has some other form of protection that can be removed?  

I loaded the thumb drive on a Windows box and it showed one partition with 128 GB.  Oddly enough though, on the Mac, it shows up as "137.44 GB Generic Flash Disk Media"  How is that the Mac is reporting an extra 12 GB when and Windows isn't seeing it?  As I got this thumb drive from an eBay seller overseas, I'm now wondering if this might be a counterfeit.  

Author

Commented:
More info:

After doing another one partition Mac Journaled format that failed, I selected the unmounted partition and did an erase using MS-DOS FAT and it mounted.  Moved the drive over to a Windows box and it said it needed to be formatted and checking the data management function, it showed one 200 MB protected partition and I formatted it.  Put it back in the Mac and successfully formatted it with HFS+ however it's only 200MB - not quite enough for a Lion install.  Tried repartitioning to combine the two partitions and it failed as before.  So the best I could do was get a 200 MB partition with HFS+
Commented:
I bought a 32 GB USB Thumb Drive and it successfully formatted - chalk this one up to an isolated issue with the other thumb drive.  

Author

Commented:
The problem appeared to be with the particular thumb drive although Strung offered good advice on GUID partition.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial