Red X when replying to email, BlackBerry

liamdye
liamdye used Ask the Experts™
on
Sometimes when I try to reply to a message on my BlackBerry I get an red X and an error "Mailbox couldn't find original message, if forwarding or replying please resend the message." Resending the message does actually work. But it's fairly annoying.

I have also worked through the possible resolutions in this KB to no success: "http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB00353"
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Viral RathodConsultant

Commented:
What is the version of Exchange server ?

Are you facing the same red X when using OWA ? Check the Same you OWA and letus know.
When i have faced this issue in the past it has usually been corrupt service books. Delete the service books (SYNC) and (CMIME) reboot the device and then resend the service books from BAS.
Failing that Remove the user from BES wait about 10 minutes for the user to actually flush and then add them back into BES, generate a password and reactive the Device

Author

Commented:
I am running Exchange 2010, no issue with OWA.

I have tried the service book repair and will let you know how it goes. I hope it works because I really don't want to have to reactivate.

Author

Commented:
Looks like the service book fix did work, I have replied to around 5 emails without the error. If it doesn't I will remove my user from BES.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial