Remote Desktop Audio Mapping Troubleshooting

seanramos
seanramos used Ask the Experts™
on
Hello,
I have a problem with a set of Dell r610's, RDP audio mapping has is not working correctly.  This just happened a few weeks back, audio has been working perfectly fine from our clients who Terminal Service into the servers. No group policies are disabling the audio whatsoever, they are under the same OU as the other terminal servers and the others are working perfectly fine.  I have made sure via RSOP.msc and checked and re checked to see if any policy was in place.  The only servers that are having this issue are identical in chipset, model etc.  Both were affected at the same time, the only thing I can think of are Windows updates that we run once or twice a month.  Perhaps corrupting the virtual MS audio drivers? I have tried updating the chipset drivers, bios, vga drivers and no luck.  I have ticked the terminal server connection AUDIO Mapping on and off several times to try to re establish audio. Used several different clients that have had success with audio in a terminal session before, same thing does not work wth the r610's but with the older Power Edges they were fine. Every time I check the Sound and Audio devices it's all greyed out saying no AUDIO DEVICE FOUND.  There are no add-in audio cards in these servers, just the virtual audio devices.  I have done a lot of research and called Dell and they are stumped as well, I don't want to have to reinstall Windows 2003 R2 on these servers just for audio, there has to be a reason why.  I have even reinstalled directx and now I'm leaning towards uninstalling .net and every update on the box.  2 identical Dell Servers and same problem, audio stopped at the same time..I don't know what else to do.  Any info would be greatly appreciated. Thanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Gerwin Jansen, EE MVETopic Advisor
Most Valuable Expert 2016

Commented:
I'm not an expert on this one but did you uncheck the "Audio Mapping" checkbox in the Terminal Service Configuration, Client Settings tab?

Author

Commented:
Yes, unticked reticked.
Topic Advisor
Most Valuable Expert 2016
Commented:

Author

Commented:
You got it!! Thanks so much, the citrix audio .dll's were different but that reg key is what i needed to change.  It was set to wysedmm.dll or something, it had something to do with a thin client software I installed about the same time the audio went dead.  I changed the mixer and wave values to rdpsnd.dll and voila! Thanks so much!!! I was going to purchase a helmet because I was tired of banging my head on the wall!!!
Gerwin Jansen, EE MVETopic Advisor
Most Valuable Expert 2016

Commented:
:) Great to 'hear' that you've got things working again!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial