Windows 7 Automatic Reboot

steva
steva used Ask the Experts™
on
I have a friend running Windows 7 who said Microsoft downloaded and installed some updates and then rebooted his computer while he was trying to give a presentation on line!

I'm still running XP but surely there is a way to make sure this never happens.

Thanks for any ideas.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
you can always configure the automatic updates according to urself.
go to control panel >> windows updates >>change settings

choose download updates but let me choose when to install or any other
instead of install updates automatically . thats's all you want to do.            ........ :-)
Most Valuable Expert 2011
Top Expert 2011
Commented:
How to Disable Automatic Reboot in Windows 7 after Updates Installation
http://www.nirmaltv.com/2010/04/08/how-to-disable-automatic-reboot-in-windows-7-after-updates-installation/
Most Valuable Expert 2011
Top Expert 2011
Commented:
Abd the registry method.....

http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_update/i-want-to-turn-off-the-automatic-restart-for/88191194-d3e7-428d-a2a5-89e427756ccc

It still leaves you the ability to leave updates installing on thier own, without having to manually do them...
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Commented:
1. Click the Start menu and type "gpedit.msc" (without quotes) in the search line and press the enter key. This will launch the Local Group Policy Editor.

2. On the left side of Local Group Policy Editor, expand to Computer Configuration > Administrative Templates > Windows Components. Then scroll down and select Windows Update.

3. Double click "No auto-restart with logged on users for scheduled automatic updates installations" option. In the properties window that appears, change the option from "Not Configured" to "Enabled". Click "OK" and close Local Group Policy Editor. Windows will no longer prompt you to restart after automatically installing updates.

That should be it.

Author

Commented:
I'm just wondering, though.  If there's a way to turn auto-reboot off through the Control Panel , as amit suggests, why would we want to use gpedit?  

And apparently gpedit is only available to Professional, Enterprise, and Ultimate versions of Windows .  Is the Control Panel option available to all versions?

Thanks

Most Valuable Expert 2011
Top Expert 2011

Commented:
I dont think the reboot supression is not an option in the Control Panel, which is why I posted both teh gpedit, AND the direct registry method.....


The Control Panel method will allow you to choose when to download them, and by virtue of that, you would know when the reboot is coming, but your not getting your updates automatically.

Author

Commented:
kszhitij,

Thanks for the response but John beat you to the gedit answer.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial