Error when upgrading from CRM 3.0 to CRM 4.0. "Action Microsoft.Crm.Setup.Common.RegisterAsyncServiceAction failed"

chome81
chome81 used Ask the Experts™
on
Hello,

We've been working on our CRM upgrade for the last two days and we're at a stopping point with this latest error.

"Action Microsoft.Crm.Setup.Common.RegisterAsyncServiceAction failed"

There seems to be a lot of info online regarding this error, but so far nothing has worked.  We tried uninstalling/reinstalling .net framework.  We tried following this KB http://support.microsoft.com/kb/949092.  Tried changing the Async Service to start as a domain account rather then the network service.  Nothing is fixing our issue.  Any ideas on how to fix this?  Seems like there much be a logical explanation...  Any help is appreciated.

Thanks!

image.jpg
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
can you please provide me the log file for this install. it would be found at location C:\Documents and Settings\{username}\Application Data\Microsoft\MSCRM\Logs\CrmAsyncService.log

Author

Commented:
Actually it appears that we were able to get thru this portion of the install without error today.  We reverted back to our 3.0 snapshots and started from scratch.  We took two actions.

One, we ran a fresh windows update to get any of the latest .NET Framework Service Packs and potentially fix any .NET files issues.

Two, we ran lodctr /r to reload any counters.  We did this previously, but this time it wasn't after manually clearing out many reg keys from the MS KB.

Our install isn't complete yet, but it did get past that stage.  Currently is 3 hours into the Workflow Upgrade portion.
ok let me know if you have any issues with it
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Author

Commented:
Any guess on how long (worst case scenario) I'll have to wait on this Workflow Upgrade portion?  Going on 3.5 hours.  It it doesn't finish soon, I'll have to abort the upgrade.  
There could be lot of factors that depend on this upgrade workflow process. Like the CRM server resources and the count of them etc.
Have you tried looking at the log file WFUpgradeInfo found in the same place where the setup log file for this upgrade

Also have a look at this link on purging up old instances of workflows
http://blogs.msdn.com/b/crm/archive/2006/10/24/purging-old-instances-of-workflow-in-microsoft-crm.aspx

Author

Commented:
Ended up aborting and reverting to my 3.0 snapshot.  Will have to kick it off again on a Friday evening so I have more time to let it run.  This time I'll delete the workflow logs prior to kicking it off.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial