Slow opening of excel docs via network share

Daniel Bertolone
Daniel Bertolone used Ask the Experts™
on
 
Just setup a new client of mine with a sbs 2008 server. Server is running 12 GB ram & has raid 1 for os & raid 5 consisting of 3 146 10k sas drives for the data.
 
The end users are suffering extreme slow down on their workstations when they to an open an excel document from the data drive. It can take up to a minute to either open or save a document.
 
I think i have narrowed it down to the on access scanner (savservice.exe) on both the server & workstation as when i disable this option the slowdown is no longer current.
 
I do realise this is a security risk but i would have thought the server specification would easily be able to handle what the client is throwing at it without any issues.
 
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
- Run SBS 2008 Best Practise Analyser tool and fix the errors reported.

- Also refer this previuosly answered question:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_24336198.html

Commented:
This is an issue with SMB (Server Messaging Block) 2.0 and OpLocks (Opportunistic Locking). You need to disable SMB 2.0, first on just the affected user’s machine and if necessary on the 2008 server it is accessing.
 
SMB 2.0 only works between Windows Vista or Windows 7 and a Server 2008 box. If you have Windows XP or Server 2003 SMB 2.0 is not your problem!
 
Disabling SMB 2.0 on Windows 7 or Windows Vista:
 
From Windows 7.0 you need to run CMD.exe in elevated mode (run as administrator) and issue the following commands:
 sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
 sc config mrxsmb20 start= disabled
 
Disabling SMB 2.0 on Server 2008
 
Note that disabling SMB 2.0 on your problem Windows 7 or Windows Vista machines is enough to stop SMB 2.0 from being used. You should only disable SMB 2.0 on Server 2008 if disabling the client desktops using the command above has failed!
 
Open Regedit and browse to this key…

HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters
 
Add the DWORD key with the name Smb2 and set the value to 0 to disable SMB 2.0.
 
Reboot the server.

Author

Commented:
I saw that option on the net but the clients are running windows xp. However the server is sbs 2008 so do you think smb could be causing the issue?
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Commented:
No, SMB 2.0 would not affect an XP client.

Author

Commented:
Attached are the bpa results. Is there anything there that could cause the slow down? BPA Results

Author

Commented:
I looked at the articles and disabled TCP Checksum, IP Checksum & TCP Offload. I also changed the duplex speed on the server from auto negotiation to 1000/Full but still get the same issues.

I have investigated further and the issue seems to be with Sophos on access scanner (savservice.exe). When i look at task manager when trying to open the document cpu activity is at 99%. When i disable the function the slow down disappears but the machines are at risk. I have since spoken with sophios and it seems there is not much else that i could try.

Could the issues raised in BPA have any effect?
I have found theissue and it appears to be with the antivirus settings on both server & client.

How do i close teh question?

Author

Commented:
The solution turned out to be that sophos was causing the slow down

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial