exchange anywhere setting in outlook 2007

cybertechcomputers
cybertechcomputers used Ask the Experts™
on
Hi, i have a issue on a windows 7 laptop with outlook 2007.

Under the setting where you enter the outlook anywhere proxy settings.

It has autodiscover.mydomain.com - autodiscover does not connect to my exchange server, but if i change it to mail.mydomain.com it connects fine.

So i changed both options that had autodiscover to mail. and everything is good.

A week later my client phoned me saying it wont connect. i went back into that setting and it had reverted back to autodiscover.

is there a way to prevent this. or is there a guide to get autodiscover to work. i have added autodiscover to the godaddy certificate and it appears as alternative subject names in the cert
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
Look info in the next page on how to setup msstd principal name.
http://faq.apnaserver.com/afmviewfaq.aspx?faqid=128

Commented:
Look info in the next page on how to setup msstd principal name.
http://faq.apnaserver.com/afmviewfaq.aspx?faqid=128

Author

Commented:
thank you for the reply, i done the get-outlook thing first, all 3 were blank.

I then completed the step to change msstd feature as suggested.

I then retried the get-outlook - it now displayed the msstd:mail.mydomain.com

the other 2 are still blank. as the same as the screen print on the link.

So this should stop the settings being reverted back to autodiscover is that right?
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Inducing autodiscover.domain.com should solves the issue, is it still appear ? any certificate error ?
OR you can change the autodiscover internal URI:
http://technet.microsoft.com/en-us/library/bb125157.aspx

Author

Commented:
Thank you for the reply, for a while there i thought it was all working and the issue was resolved unfortunately not. i got a phone call this morning advising it had changed back. double checked and fair enough. back to autodiscover.

i completed the step to change msstd feature as suggested. but this has not resolved the issue

no certificate errors, certificate is from godaddy

Sulimanw: - are you suggesting adding autodiscover to the subject alternative name
Yes I do. but first please try to create an srv record for autodiscover in your external domain (DNS). if that solved the problem then no  need.

Author

Commented:
Hi. Sulimanw. I have just received an email from my customer advising it has happened again. I have just done a bit of research in regards to the srv record. Is this record only designed if the exchange server is located on another public ip address or can it be used internally aswell.
Can be used in both internal and external DNS.

But, internally the client will first check the SCP for autodiscover, so SRV record in internal network is useless....  had you change the internal autodiscoverURL as in comment: 35767823?

a very useful white paper about autodiscover in exchange server:
http://technet.microsoft.com/en-us/library/bb332063(EXCHG.80).aspx

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial