Remote Desktop Gateway - Certificate Revocation

LeviDaily
LeviDaily used Ask the Experts™
on
We have a Remote Desktop Gateway server that users from the outside connect in on. All works well, except for a few random users. They get the error "Your remote desktop connection failed because the remote computer cannot be authenticated." "The remote computer could not be authenticated due to problems with its security certificate. It may be unsafe to proceed."

Certificate errors
"A revocation check could not be performed for the certificate."

I am outside the office now and am accessing the server remotely. No idea where to go here especially since it is only on random computers. This is a GoDaddy SAN certificate. I just purchased it.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
systechSenior Technical Lead

Commented:
When you launch MSTSC click on options, then on the Advanced tab you have the Server Authentication section, Make sure the drop down box is set to Warn me, this should prompt you if there are any errors with the cert.

Also delete any old certificate listed in the store, Clients may getting the old certificates rather than your Godaddy SAN cert.

Also check the RDP versions, And also confirm the firewall settings in Windows server 2008. As its not bolcking any RDP clients which is using older vertion of RDP.

Check this link whether it helps you http://www.satheesh.net/2009/11/09/certificate-error-for-remoteapp-ts-web-access/

"Good Luck"

Author

Commented:
Thank you for the fast reply!!

1. The Warn Me on server authentication is checked.

2. Are you talking about deleting old certificates on the client? If so, is it under Local Computer or Personal store?

3. Not sure what you mean on the firewall? We dont use Windows for our firewall.
systechSenior Technical Lead

Commented:
Yes, I am talking about deleting old certificates from personal store, Windows firewall is system state, If it is not using then disable it if already not done so
The problem was the clock.

Author

Commented:
My problem was because the clock was wrong. Once I figured that out, it worked.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial