exchange 2010 on sbs 2011

Sid_F
Sid_F used Ask the Experts™
on
I get the below error message when sending mail internally on a newly installed server. the address does exist and the mailbox looks fine, any ideas

Delivery has failed to these recipients or groups:

user@mycompany.com <mailto:IMCEAEX-_O%3DDEC_OU%3DFIRST%2B20ADMINISTRATIVE%2B20GROUP_CN%3DRECIPIENTS_CN%3user@mycompany.com>
The e-mail address you entered couldn't be found. Please check the recipient's e-mail address and try to resend the message. If the problem continues, please contact your helpdesk.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2011

Commented:
Hi,

Is this a reply to a imported e-mail, or are is the mail address loaded from the .nk2 file cache from outlook have you tried to select the mail account directly from the address list by clicking to and select it.

Author

Commented:
ok so the problem seemed to be with the nk2 file event though I did not let it autocomplete the error message kept appearing when I did let it autocomplete it had the correct address but still problem. I deleted the nk2 entry and it worked fine. so this looks like there is something more in the nk2 than just the address, to give some background this user was moved from a previous sbs 2003 server, there mailbox was reimported from pst and the nk2 file copied over from previous profile
Top Expert 2011
Commented:
The nk2 kept for users on the same exchange server as itself not just the email address but the unique identifier and after moving to a new exchange server this unique identifier cannot be found. So by simply deleting the entry from the nk2 file this identifier is removed and it will just send to the right email address.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial