Google indexing issues on website

Web_Sight used Ask the Experts™
Hi All,

We are working on a multi-lingual website for learning languages and have used URL rewrite feature to display User profile, Product pages etc.

Ex: Please see URL format  below for the tip detail page,-I'm-sorry-.html

Here 'en' stands for English language, similalry we use 'fr' for French and have about 12 languages on the site currently. The en, fr etc are taken from a session variable when a user logs into the site
We recently did a lot of work related to SEO Optimization and the URL rewrite was part of it to get all these pages indexed by Google.
We also submitted the site to Google for verification and have a sitemap file also in place on the website.

However, when we do google search for the tip based on tip name, user profile name or product name, the language parameter "en" is missing from the search results returned by Google.
The URL as seen in the results is -,-I%27m-sorry-.html

The langauge identification value is supposed to be available just before the '-146' in the URL above. This is the case for all languages.
There are no issues if a user is browsing the same pages directly in the website (not from Google search results).

Does anyone have any feedback as to why this happens and what can be done to resolve this? There are a set of images, text etc that load based on the language parameter value.

Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Most Valuable Expert 2011
Top Expert 2016
Couple of thoughts.  If you get a URL like this:,-I%27m-sorry-.html

Maybe rewrite it to something like this:,-I%27m-sorry-.html

You could use a service like to decide what country you might use for the rewrite.

The other thought, maybe you want the URLs to be like this, with a separate directory for each language.  That is the way handles it, and it seems to be a successful design pattern,-I%27m-sorry-.html


I've requested that this question be deleted for the following reason:

No comment has been added to this question in more than 21 days, so it is now classified as abandoned and is now flagged for deletion.

If there is a valid solution, please OBJECT and indicate the comments that are, or would otherwise lead to, a solution.

Use the specific format https:#axxxxxxxx for comment ID(s).

Also, please don't object simply because the author did not respond to your comment. While we understand this is frustrating, unfortunately we cannot force the author to return to the question. Unless you feel you have presented a valid, verifiable solution we'll simply delete the question.

Experts-Exchange Auto Deleter
Most Valuable Expert 2011
Top Expert 2016

From the look of this and some other questions posted by Web_Sight, the Author did not understand that there was any need to close a question, so just wrote "thanks."  The correct answer is here: https:#a35769598.  This question or one like it was asked frequently and became one of the inspirations for my article:

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial