Cisco ASA 5505 ISP Connection?

Railroad
Railroad used Ask the Experts™
on
So our new ISP gave me our IP allocation:

WAN IP: x.x.x.10
Subnet: 255.255.255.252
Def. Gateway: x.x.x.9

Additional Allocation x.x.x.128/28

I've configured the ASA, as seen in the code below, and the device can ping devices out on the Internet.  I've changed the def. gateway on one of our machines to use 192.168.20.1 as the def. gateway, but I can not access anything on the Internet.  I would have thought the ASA would have NATed everyone using the x.x.x.10 IP address.

I'm guessing I'm missing something simple, ideas?

In addition,

How do I configure the ASA to allow me to forward the additional IP allocation to machines on my network.  I understand how to do it when the IPs are part of the original subnet, but not sure how to add a second subnet which the ASA "controls".

Thanks in Advance
: Saved
:
ASA Version 8.2(1) 
!
hostname FIREWALL
enable password * encrypted
passwd * encrypted
names
!
interface Vlan1
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Vlan2
 nameif outside
 security-level 0
 ip address x.x.x.10 255.255.255.252 
!
interface Vlan20
 nameif inside
 security-level 100
 ip address 192.168.20.1 255.255.254.0 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
 switchport access vlan 20
!
interface Ethernet0/3
 switchport access vlan 20
!
interface Ethernet0/4
 switchport access vlan 20
!
interface Ethernet0/5
 switchport access vlan 20
!
interface Ethernet0/6
 switchport access vlan 20
!
interface Ethernet0/7
 switchport access vlan 20
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup outside
dns server-group DefaultDNS
 name-server x.x.x.x
 name-server x.x.x.x
same-security-traffic permit intra-interface
access-list outside_access_in extended permit icmp any any echo-reply 
access-list outside_access_in extended permit gre any any 
access-list outside_access_in extended permit tcp any any eq pptp 
pager lines 24
logging enable
logging asdm informational
logging host inside 192.168.10.33
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.9 1
route inside 192.168.10.0 255.255.254.0 192.168.20.80 1
route inside 192.168.30.0 255.255.255.0 192.168.10.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL 
http server enable
http 192.168.10.0 255.255.254.0 inside
http 192.168.20.0 255.255.254.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh 192.168.20.0 255.255.254.0 inside
ssh 192.168.10.0 255.255.254.0 inside
ssh 192.168.30.0 255.255.255.0 inside
ssh timeout 15
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username * password * encrypted privilege 15
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect pptp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:b57d248707bdd4b0e24b500f30e0737f
: end

Open in new window

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Senior infrastructure engineer
Top Expert 2012
Commented:
First try adding: nat (inside) 1 192.168.20.0 255.255.254.0
Ernie BeekSenior infrastructure engineer
Top Expert 2012
Commented:
For the additional range you can just set up the static (inside,outside) commands. The ISP should have set up a forward for that range to the ip of the ASA. It will then just 'catch' those addresses even if it's outside interface isn't in that range.

Author

Commented:
I knew it was simply, I just couldn't remember the command, even after staring that the configuration of my other ASA.

Sweet thank you!  All is working as expected.
Ernie BeekSenior infrastructure engineer
Top Expert 2012

Commented:
Glad I could help :)

And thx for the points.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial