cannot open Excel file, have to open excel first, then open file

tucup
tucup used Ask the Experts™
on
I have office 2007 professional installed on XP Pro. This was connected to domain for our office but now this PC is setup at a remote office and connects via VPN.
Everything runs fine, email, word IE8 etc.

Problem is, when I click on an Excel file (local or remote) it opens Excel but not the file itself. I then have to open file from the menu.

I have tried a number of suggested fixes available on the net and uninstalled office, re-installed it, and updated service packs with no luck.

I now have been told the second PC at the remote office is suffering the same issue with Excel.

Any ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
I would suggest you run diagnostic on your excel
1) open Excel 2007
2) Press on the upper left corner Office Icon and choose Excel Options (lower right button)
3) Select Ressources from the left hand options
4) Select Diagnose for run Microsoft Diagnostics.

It should look and chek if your Excel is ok and re do all standard links.
gowflow
If my above suggestion doesn't improve your situation run Windows update and make sure all your latest updates are installed for your Microsoft Office product. It goes the same on your remote PC that is suffering the same issue.
gowflow
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
thanks guys, I will try these solutions out thursday and post back here thursday evening to let you know how I got on.
What OS are you using, it may be that your file association had gone funny. In Explorer, go to Tools and folder options. I think it is under File Types.
In Win 7, goto Control panel, Default Programs and Associate a file type.....
Select the XLs type and make sure it is opening with Excel, if not, select it from the list or choose browse and go to the excel.exe in program files/Microsoft Office/office?? folder

Author

Commented:
Sorry for the delay guys,

Tried diagnostics and service packs but didnt work.

What did work was Twiqahils link, which suggested the following:

1.First, open any folder in Windows XP.

2.Click on the Tools menu, and choose Folder Options.

3.From the dialog that pops up, click the File Types tab. You will now be presented with a list of all document types recognized by your computer.

4.Scroll down to XLS, select it, and click the Advanced button. Now you'll see several "Actions" registered for Excel worksheets.

5.Usually, Open is the default (indicated by being in bold). Select "Open" and click the Edit button.

6.The main piece of data in here is the field labeled "Application used to perform action". This should point to your Excel executable, followed by some command-line arguments. Here's how it appears on my PC: "C:\Program Files\Microsoft Office\Office\EXCEL.EXE" /e "%1"

7.It is very important to make sure that the %1 is surrounded by quotes. %1 is the variable representing the full path and file name of the document you are opening. If it contains any spaces, and this is not surrounded by quotes you will get a flurry of weird errors.

8."Use DDE" is normally checked. Now, make sure that "DDE Message" is empty. Click OK.

9.Click OK back at the Edit File Type dialog. Click Close on the Folder Options dialog.



Thanks, problem solved, I hope this help someone else out, and thankyou to gowflow amd marksitwell for your help.

Author

Commented:
Thanks, this worked a treat with Excel files not opening properly

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial