Joomla re-installation problems

Eternal_Student
Eternal_Student used Ask the Experts™
on
Hi,

I recently upgraded Joomla from Version 1.5.3 to 1.5.23. I did this by deleting all the files and re-uploading. I also re-installed K2 and JCE. Most things seem to be OK but I have a few issues which I could do with some expert help with.

1) Certain k2 items at a category item list level are not appearing? It is outputting the mark up, for example one category has 9 items and it is outputting the 9 divs but no content?

2) JCE problems. I have re-installed JCE but when I look at existing items the editor does not appear? So the content is there in a field but the editor doesn't exist? If I create and save a new item the editor is there but if I go back to edit it, it is gone again?

Any help on these would be very grateful, thanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
2) You will have to set JCE for your default editor at Joomla configuration page and on your user settings at User manager
Panagiotis Sweb developer - designer

Commented:
why dont yo upload the upgrade patch?

if you have a backup of the 1.5.3 install it and aply the patch, its the safer way

Author

Commented:
@ V4nP3rs13 ... I have tried this already.

@ panagiotiss ... because the site was hacked and I needed to make sure all of the files were completely clean, so I re-uploaded everything from scratch.
Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Keep us updated on your progress.

Regarding the divs there but no content, are you seeing anything in the page's source code?

Rowby

Author

Commented:
@ Rowby ... the mark up is there but nothing in the mark up?
Are you sure your javascript is enabled in your browser ?? Try with other browser and see if it is browser's or website's problem

Author

Commented:
Yea my Javascript is enabled. Tried with other browsers and I still get the same outcome.
Panagiotis Sweb developer - designer

Commented:
try to restore an older  backup  and then update

Author

Commented:
BUT ... this could be a clue, I got a javascript error in IE 8:

Message: 'tinyMCE.activeEditor.selection' is null or not an object
Is it pure HTML that you are typing into the editor?   Or does it include iframes, javascript etc.

Also in the parameters in your Article Manager do you have your Blacklist set like the attached?  (not sure if this could be the issue, but it is most likely a step you need to take.  Especially if you are using irames and javascript etc.

 
joomla-experts.jpg

Author

Commented:
No iframes or javascript in the editor just images and code.

Also you might try using this editor:

http://extensions.joomla.org/extensions/edition/editors/90

It's a quick install.

Author

Commented:
Ideally I want to get JCE working as it was, just cant figure out what is going wrong?
I understand that you prefer jce, but if you can get the other editor working it would help troubleshoot the issue.

You can always uninstall the other editor and go back to jce.

ROwby

Author

Commented:
I will try and install another editor tonight and see how I get on.

Would you say it is better to do that or copy /editor directory files over from the old site?
First try indtalling the new editot.

Author

Commented:
Turns out I needed to edit some of the php files as this is a bug with JCE.
Hi Eternal_Student:

To help others who might experience this issue, can you post a link to the "article" or whatever that addresses this issue.   That will help anyone who is searching Experts-Exchange having the same problem.

Happy you were able to resolve it

Rowby

Author

Commented:
Good point - although I never actually bookmarked the thread that had the solution in it!

But this forum here has some very helpful people and existing posts:

http://community.getk2.org/forum
Thanks!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial