Link to home
Start Free TrialLog in
Avatar of jkimzlg
jkimzlg

asked on

Wake-on-Lan no longer works

Wake-on-Lan used to work.  I had a cisco 1760 router and was able to turn my pc on remotely from the Internet using http://wakeonlan.me.  I recently switched to a cisco 871w.  I am trying to turn on my pc with the ip 192.168.1.6.  This is part of my configuration, am I missing something?


interface FastEthernet0
 switchport access vlan 2
 duplex full
 speed 100
!
interface FastEthernet1
 switchport access vlan 2
!
interface FastEthernet2
 switchport access vlan 2
!
interface FastEthernet3
 switchport access vlan 2
!
interface FastEthernet4
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
!
interface Vlan2
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source static udp 192.168.1.6 7 interface FastEthernet4 7
ip nat inside source static tcp 192.168.1.6 7 interface FastEthernet4 7
ip nat inside source static udp 192.168.1.6 9 interface FastEthernet4 9
ip nat inside source static tcp 192.168.1.6 9 interface FastEthernet4 9
!
access-list 1 permit 192.168.1.0 0.0.0.255

arp 192.168.1.6 10ab.40a2.2bc2 arpa
Avatar of ts4673
ts4673
Flag of United States of America image

Check out a product called poweronmypc.com
it's free for up to 10 machines, does wake on lan over the internet and doesn't need any router rules. You just download and install a tiny app on one of your servers and you are done.  
Avatar of Soulja
Try adding ip directed-broadcast to interface vlan 2. Let me know if this works for you.
Avatar of jkimzlg
jkimzlg

ASKER

I now have the following but didn't seem to work.

interface Vlan2
 ip address 192.168.1.1 255.255.255.0
 ip directed-broadcast
 ip nat inside
 ip virtual-reassembly
Have you entered the commands:

ip forward-protocol udp 7
ip forward-protocol udp 9
  ?

Avatar of jkimzlg

ASKER

soulja, I entered your commands on privileged EXEC mode and it gave me the following output:

interface Vlan2
 ip address 192.168.1.1 255.255.255.0
 ip directed-broadcast
 ip nat inside
 ip virtual-reassembly
!
ip forward-protocol nd
ip forward-protocol udp echo
ip forward-protocol udp discard
no ip http server
no ip http secure-server
------------------------------------------------------------------------------------------------------
I still think that my issue may be that Ido not have the mac-binding set up properly because when I do a 'sh ip arp' this is what I get, notice the 'Vlan 2' interface is missing from the pc I want to WOL.

871W#sh ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  38.3.43.3              -   0000.9d29.9870  ARPA   FastEthernet4
Internet  192.168.1.1             -  0023.9d49.9e36  ARPA   Vlan2
Internet  192.168.1.32             2 0023.d49b.fd52  ARPA   Vlan2
Internet  192.168.1.14            64 0023.d49b.fd33  ARPA   Vlan2
Internet  192.168.1.23            1  0023.5d4b.4d17  ARPA   Vlan2
Internet  192.168.1.6            -   10ab.40a2.2d42  ARPA
Internet  192.168.1.130         114  0023.cd47.ad40  ARPA   Vlan2

I've tried adding the command 'arp 192.168.1.6 10ab.40a2.2d42 arpa vlan 2' but I get the error msg: 'Bad ARP command - Interface may only be specified when bridging IP', any other suggestions?
Okay, remove that arp command as I don't think you need it and then enter this:

ip nat inside source static udp 192.168.1.255 7 interface FastEthernet4 7
ip nat inside source static udp 192.168.1.255 9 interface FastEthernet4 9
try assigning the ip directed-broadcast command to the interface itself instead of the vlan.

with poweronmypc.com you would have been done days ago.
ASKER CERTIFIED SOLUTION
Avatar of jkimzlg
jkimzlg

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Hmmm. I have Wake on Lan working at home and never had to use that command, just directed broadcast on my vlan interfaces and allow the udp port through my inbound ACL.
The original question that was asked was correctly answered by the group, therefore points should be awarded.  
Avatar of jkimzlg

ASKER

if anything u should be giving me ur points as I've just explained to you how to do this without using 3rd party software (laughable)
Avatar of jkimzlg

ASKER

Turns out it was just my PME (Power Mgmt Event) setting in the bios that was disabled.