Choose IE9 Extensions for a File Type?

coder1313514512456
coder1313514512456 used Ask the Experts™
on
I have a situation where an IE9 user would like to have .mp3 files clicked on in IE9 start in Windows Media Player.  With IE8, this was not an issue.  IE9 wants to open it in QuickTime.  I would normally just disable the QuickTime add-on, however, the user wants the QuickTime plugin for other things.  So that is not an option.

So, how do I keep the QuickTime plugin for other items but make it so when she clicks on an mp3 inside IE9 it opens Windows Media Player, instead of the browser QuickTime plugin?

(Important:  for now I'm having her save the mp3 and then opening it in Windows Explorer.  Not the elegant one click solution I'm looking for here.)


(Edit:  just cleaned up the wording a little.)

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
i think the quicktime player must be playing the mp3s by default even when opening through windows explorer right?
if this is the case.... then SHIFT+Right click on any mp3 file in windows explorer or my computer ... click Open With and select Windows Media Player (in either Recommended or Other Programs) . Be sure to check Always use the selected program....
Since u r using IE9, u must be using either Vista or 7 ... it works this way on 7 .. should work on Vista too
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Author

Commented:
I double checked this and it appears that shift-right click isn't working here.

It is Windows 7, it's just that "Open With..." isn't an option.  She has Open, Open in New Tab, Open in New Window, and some miscellaneous stuff like print the link or accelerator options.

Perhaps something is messed up with her browser?  What would prevent that menu item from showing?   Or, another question, what might allow something to show her a completely different menu?

I'm not sure what to do on this.


hey ... that "Open With" option doesn't appear in Internet Explorer... it appears when you SHIFT+Right click an mp3 file in My Computer or Windows Explorer...

you have to change the file association.... just SHIFT + RIGHT CLICK any mp3 file in My Computer ... Click 'Open With' and select Windows Media Player ... be sure to put a check on the 'Always use the selected program...'

Author

Commented:
Ok, I've checked on 3 different Windows 7 machine and a Windows 2008 R2 Server machine.

All are running IE9 and none of them have an "Open With" menu option that I can find.  They all use different security technologies, and I know that 3 of the 4 machines definitely have all the latest updates.

Any other ideas?  Something in the registry that could modify this to make it work?

Author

Commented:
navaidfarooqui:

Somehow I missed your comment earlier.

There is no problem with using Windows Explorer; the file types defintions (as well as the Open With menu option) are working fine there I believe.

The problem is within IE9.

Inside IE9, I am trying to make it so that when she clicks on an mp3, it does the same thing that IE8 did; to open with Windows Media Player (WMP).

I have tried the file associations already, making WMP the default for explorer started mp3s.  That's not the issue.

The problem is, like you said in your earlier post, inside IE9 it will open a new IE9 window and then use the QuickTime plugin, instead of using the windows plugin, or just using the Windows Media Player.

I don't see a way to assign it, and I don't want to disable the QuickTime plugin.  I can't find a way to prioritize plugins either, nor can I choose different assignments nor default plugins for particular file types.

This should be a fairly easy thing to do, I just can't see how to do it.  And again, in IE8 it was working for her without any trouble whatsoever.


as i said above ... the Open With menu option is not present in IE9 .. it is just a native My Computer option... anyway ... you can do this then

on Windows 7 Machine..

Click Start -> select 'Default Programs' -> click 'Associate a file type or protocol with the program' -> After the loading is complete ... look for '.MP3' extension -> select that and click on 'Change Program' button -> Select Windows Media Player and click OK
actually in IE9 ... the file associations are combined with the Windows File associations... so whatever the association you set with Windows Explorer ... it will automatically be set with IE9
also remove the Mp3 Association from within the Quicktime Player
Most Valuable Expert 2011
Top Expert 2011

Commented:
If they are natively opening in Explorer under WMP, I dont see where the change is coming from in QT. Perhaps QT has an option in it, or iTunes even?

Author

Commented:
I have the latest of both the programs, however, neither of them has the "File Types" tabs referenced in the solutions.

So, still no luck.

For Latest Quictime Player

 to remove the plugin associations in quicktime

go to Edit-> Preferences -> Click Quicktime Preferences -> Open Browser Tab -> Click MIME settings ... scroll down till you see .mp3 .... Uncheck the box next to it....

Now to assign it to Windows Media Player

Start -> Default Programs..... you will have to set .MP3 file association to Windows Media Player from there

Windows 7 handles all the file type association in a centralized location so you won't see separate tabs in both players


Author

Commented:
Found it at last.


navaidfarooqui:

I had already unchecked the mp3 in Quicktime > Browser > MIME.
The Start > Default Programs was also already done.

I wouldn't have gone digging into this had you not made such a point of those dialogs. Thank you.


Here's how I got it to work:


For the IE9 browser, I had to:

1.  Close IE first (of course, as always)

2. Start > Default Programs > "Set program access and computer defaults" > Custom > Choose a default media player = Windows Media Player > OK

THEN

3. Start > Default Programs > "Set program access and computer defaults" > Custom > Choose a default media player don't select QuickTime but DISABLE access to the program > don't click OK just go to next step

THEN

4. Choose a default media player = Windows Media Player > OK

THEN

5.  Launch IE9 and click on a mp3 and it plays from WMP.


What a pain!


Thank you navaidfarooqui, again, really appreciate you staying with my question.  Usually people just drop it and go away. I wouldn't have found this without you.


-- coder

Ok, I typed that kind of fast and there's some steps you don't need.  You don't need to close IE or select WMP twice, for the record anyone that's interested, just do this:


1.  Start > Default Programs > "Set program access and computer defaults" > Custom > Choose a default media player don't select QuickTime but DISABLE access to the program > Select Windows Media Player > OK

2.  "Set program access and computer defaults" > Custom > Choose a default media player don't select QuickTime but re-ENABLE access to the program > OK


That's it.  This works on IE9 and IE10 preview under Windows 7.


-- coder

Author

Commented:
navaidfarooqui here helped me get through the maze of preferences and his suggestions helped me find the solution I was looking for.

We kept getting hung up on trying to use "Set Program Defaults" or "Associate a File Type" when the real solution was hidden away in "set program access".

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial