Invalid credentials when attempting to use IMAP SSL with Exchange 2003

Mandr1ch
Mandr1ch used Ask the Experts™
on
Hello,

I'm in the process of enabling IMAP SSL for an external user. I've looked over the documentation and am pretty sure I've followed the correct procedures. This is for a Exchange 2003 SP2 on SBS 2003. In a nutshell, I have done the following:

- Enabled the IMAP service for auto start.
- Tested IMAP (143) successfully from outside.
- Forwarded Port 993 to the server from the firewall.
- Ticked the box in the default virtual IMAP  server to require SSL.
- Applied a self-signed certificate.
- Verified the port numbers for unencrypted and encrypted IMAP traffic under advanced.
--------------------------------------------------
The Error:
Your IMAP command could not be sent to the server, due to non-network errors. This could, for example, indicate a lack of memory on your system.

Configuration:
   Account: DOMAIN(testacct)
   Server: mail.domain.com
   User name: testacct
   Protocol: IMAP
   Port: 993
   Secure(SSL): 1
   Code: 800ccc0f
--------------------------------------------------------------

I've tried establishing a Telnet connection to port 993 but the connection times out. This is both externally and from the localhost. I do have Routing and Remote Access enabled for VPN connectivity and wonder if this might ahve something to do with it. Though I checked for NAT/Basic Firewall under the RaRA settings and it is not an option the is present.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
if you are unable to telnet to 993 from local host , then the IMAP SSL isnt working. It has nothing to do with the firewall or RRAS. Check the IMAP settings to see if SSL is configured to use port 990. Also check if your local LAN firewall on network connection allows traffic on port 993. You must be able to telnet if all is configured correctly.
Top Expert 2015

Commented:
Maybe you have mail-filtering antivirus which does not allow SSL connections.
Top Expert 2010
Commented:
Review http://www.smallbizserver.net/Articles/tabid/266/Id/231/Configuring-IMAP-over-SSL-with-SBS-2003-Standard.aspx and double check all steps. This article has you assigning a certificate to smtp also.

Hope this helps

Author

Commented:
Sorry for the delayed reply and misnamed title of this question. Changed the text without changing the title. Turns out it was the SMTP certificate.  Thanks for the replies!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial