troubleshooting Question

ubuntu RAID issue - Software - different data on drives

Avatar of bmsjeff
bmsjeffFlag for Afghanistan asked on
Linux
9 Comments1 Solution417 ViewsLast Modified:
I have no Ubuntu experience, so any help would be grateful.
I was getting this error.
/dev/sda1 clean
fsck 1.40.8
/dev/md0 contains a file system with errors, check forced
Duplicate or bad block in use!
/dev/md0: Multiply-claimed block(s) in inode 8: 24576
/dev/md0: Multiply-claimed block(s) in inode 4981200: 24576

I ran:
df -h
/dev/sda1      19g      749 used      17g available
/dev/md0      128g      27g used      95g available

cat /proc/mdstat
md0 : active raid1 sdb3[1] 134801344 blocks [2/1] [_u]

I ran DLGDIAG on both drives and they are ok.
There was a bad stick of memory that has been removed.

I  run Live CD on Drive0
fsck
Errors corrected on Drive0
Drive Boots properly

Live CD on Drive1
fsck
Receive error "No usable shell was found on your root file system" on Drive1

When I look at Drive 0, there is no data on it new than 5/2/11
The data was there before I pulled the drives.
I assume this is a problem with the RAID

I ran DiskInternals and saved the Drive1 data to my Windows PC

When I try to boot to Drive1 it just sits there, nothing

What steps should I take?

If if run this on Drive0 alone I get
cat /proc/mdstat
md0 : active raid1 sdb3[0] 134801344 blocks [2/1] [U_]

Could Drive1 be a grub problem?  Not sure what steps to take next.
ASKER CERTIFIED SOLUTION
Kerem ERSOYNetwork and IT Manager

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 9 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 9 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros