DST*.tmp files being created in c:\windows\temp folder.

dwightd1968
dwightd1968 used Ask the Experts™
on
I have set mailbox limits of 15MB, changed the temp and tmp both to %systemroot%\temp verified permissions to the windows\temp directory, verified no outgoing messages in the queues, flushed the connector, set it to send HELO, all to no avail.  The files are still being created.  

Environment is SBS 2003 with exchange, EXchange SP2, fully patched.

Right now I am rebooting every few hours as the DST files are 225Mb each and fill up my partition rather quickly.  The files are being created aabout every 15 minutes.   I only have 16.3 GB of space available on the partition and the system slows down terribly.  I have 2 users that connect via terminal svcs from a remote office to do their work and this slows them down.

I have pulled out my hair, removed the A/V software, read every forum and applied everything I can think of.  Any help would be greatly appreciated.

Thanks,

Dwight
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
do you know what process is creating the files?  Use this tool to check: http://ccollomb.free.fr/unlocker/ and let me know, then I can see if i can help you more.

Author

Commented:
Process identified as locking the file is inetinfo.exe

11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Commented:
iis itself makes no tmp files so it's probably a component in it?  You will have to do a live debug to figure it out but you'd better contact MS support for that.

Some pointers:
- are all updates installed
- do you see any weird plugins in IIS?
- maybe iislogs show something
- do a virusscan could be a bot (housecall.trendmicro.com)
- any weird messages in eventviewer concerning iis / inetinfo

Author

Commented:
Okay...here is what I have found out this morning.  I stopped the batch file I wrote to auto delete the dst files on restart.  I opened the dst*.tmp file with MS Word and it is an email message that someone had tried to send with about 225MB of attachments.  I had the user delete the email from the sent items folder and from the deleted items folder as well.  I see no messages in the exchange queue under system manager but the files are still being created.  Is there a way to force exchange to lose this message?

Author

Commented:
If I set the keep deleted items on the mailbox store for 0 days will this get rid of the message since it was deleted from the users Outlook client?  This is absolutely driving me insane but I have hope now that I know it is an email message.

Commented:
so the mail is out of the user it's OUTBOX folder also?

i would stop iis: iisreset /stop
i would also stop smtp service and any antivirus that is linked to exchange

when everything is stopped delete all tmp files.
Also have a look in your mailroot folder normally this is in your exchange installation.  There you have some dirs make sure there's is no big email file left there still.

Restart everything see if problem persists.

Author

Commented:
I tried that and also checked the mailroot folder, no large messages still there.  I set the server to keep deleted messages for zero days rebooted and it is still creating the dst*.tmp files. What is causing this bad message to still be active.

Commented:
to be 100% sure this is one email that was oversized that is causing all this?  No traces of other email traffic exists that are causing this behaviour?

Commented:
also what is your Global Message size limits in ESM?

Author

Commented:
Yeah, I let a few build up then rebooted without deleting the dst.tmp files and opened them all with MS Word and they are all the same email message.  Word opens the message perfectly as the user has word set as the email editor in outlook.  I have followed the advice in KB899392 and even went so far as to set all users to have full control to the Windows\temp directory and even created an "Everyone" group to have full control to the temp directory.  

Author

Commented:
Message size limits were set to unlimited, now they are set to 15000KB  for incoming and outgoing....

Author

Commented:
Maybe....I have set the SMTP connector in system manager to never run on files over 25MB and so far so good.  I will update this tomorrow and let you know if this is resolved.

Author

Commented:
Six hours and no DST files being created.  So far so good.

A run down for the next person facing this issue.
I wrote a simple batch file that would delete the DST files automatically on a reboot to clean out the drive when it was full.... a simple del c:\windows\temp\dst*.tmp placed this in the startup directory so it would delete at logon.

I placed this on hold and rebooted and opened one of the DST using MS Word.  It opened and I could see it was an overly large email a user had tried to send (220Mb of attachments)

I went into system manager and went into the smtp connector properties and on the delivery options tab I placed a check in use different delivery times for oversize messages and set the limit to 25000Kb and then told it to Never Run so the oversize message would not try to send and build the large dst*.tmp file.  

I also applied the information in the previous posts all to no avail.  I had the user delete the email from his inbox and also set the server to keep deleted messages for 0 days (which I will change back to 15 in a few days).  

Hope this helps someone in the future.

DD
Commented:
thx for the update.  Seems something was stuck in your SMTP, I doubt deleting the email from the inbox had anything to do with the fix though.

Author

Commented:
works now.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial