Routing seperate Networks

mark1per
mark1per used Ask the Experts™
on
Hi,

It's been a very long time for me with this stuff and need some help.

I am trying to seperate my users from my servers based on the existing network setup.
currently everything here is on 10.2.99.x 255.255.255.0 so we are running out of IP's for our infrastucture devices (servers, printer etc.etc.)
What I was thinking was add another network 10.3.99.0 255.255.255.0
Am on the right track, or am I over complicating it?  If I am on the right track using cisco devices how do I get the routers 10.3.99.1 and 10.2.99.1 to talk.

Thanks in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
You are on the right track.  Setup VLans on the cisco routers
and you can add routes
I cant rememer the exact command in Cisco but it should be something similar to:
ip route 10.2.99.0 255.255.255.0 .3 gateway
ip route 10.3.99.0 255.255.255.0 .2 gateway

he gateway will be whatever is doing the router so most likely the switch.

Author

Commented:
Do I need to go through all that?

What if I instead give all my users 10.2.95.x could that work if my Servers will accept that?

Commented:
You have to give some kind of route for the switches to know how to pass traffic.  This is the proper way and I would not recommend any other way.
Senior Systems Engineer
Top Expert 2013
Commented:
The best practices is to seperate users, servers and printers each on separate.

If you don't want to do all that work by changing the existing setup, then adding the new network on a new vlan is the way to go.  You can simplify the routing though by using either rip or eigrp on the router that both networks connect to.

enable
configure terminal
router eigrp 10
no auto
network 10.2.95.0 0.0.0.255
network 10.3.95.0 0.0.0.255

If you have layer 3 switches you can configure routing on the switches.
There is lots of ways you can do it, depending on your network topology and Cisco routers you are using.

If you have one router, you can configure interface to the switch as 802.1Q trunk by creating subinterfaces:

! Assuming servers and printers are in VLAN 10, and users in VLAN 20
interface FastEthernet 0/0.10
 encapsulation dot1q 10
 ip addr 10.2.99.1 255.255.255.0
!
interface FastEthernet 0/0.20
 encapsulation dot1q 20
 ip addr 10.3.99.1 255.255.255.0
!


As both networks are directly connected to router, you don't have to use any dynamic routing protocol, or any static route. Just set default gateway on hosts in each VLAN to corresponding IP addresses on router.

If you have L3 switch, you just need to create VLAN interfaces and enable routing:
interface vlan 10
 ip addr 10.2.99.1 255.255.255.0
 no shut
!
interface vlan 20
 ip addr 10.3.99.1 255.255.255.0
 no shut
!
ip routing
!


If you can post your topology and Cisco devices models, I will be able to help you more precisely.

Regards!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial