Computer joined with domain can't get IP when off network

SJATechsupport
SJATechsupport used Ask the Experts™
on
Hi all -

Here's the deal.
I have a user who has a company issued laptop that is joined with our domain.
On our network, he can get an IP address when both wired and wireless.
When he is not on our network, however, he can only get an IP address when connecting to a wireless network. When he tries to plug an Ethernet cable in, it gives him an invalid IP address. I have tried statically setting the IP address to no avail - there is no connectivity.
Any idea what could be causing this? Again, when he is on the domain, everything works fine (via DHCP and statically).

Thanks!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
When he is off network is he using power or battery?
Often the laptop will disable the network port when running on battery to conserve battery power.  You can go into device manager and properties and power management and make a change to not allow power control of the nic.

Author

Commented:
It does the same thing on both AC power and battery.

Commented:
I only have 2 other thoughts, but neither makes much sense to me.
1 Remove and add back to domain.  This technically should do nothing.
2 Remove the nic and reinstall with latest driver. Again I would not expect this to work either.

Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Won't be able to test either option until he takes the laptop home tonight, but will do both of those things
Anything in your (AD) policies that would interfere with the wired NIC?
Some firewall or security settings ?

Is he the only person who has this issue?

Author

Commented:
Nothing that I can see.. There may have been one other person with the same issue but I haven't had a chance to take a look at their computer to tell. That being said, 50+ users DON'T have this issue.. :\
Can you run some tests?
Sometimes, it could be that the DHCP server on the "non-AD" wired LAN has an issue.
I remember that I had a DHCP server that had recorded a "BAD ADDRESS" for one MAC address and then did not give a correct IP configuration to that particular host's Wired NIC.
Removing the existing lease/reservation entry solved the issue.

How many wired LANs has the user tried?

Author

Commented:
It's not our DHCP server that has a problem - it's when the user takes it home. He has a DSL modem that plugs directly into his desktop. When he brings his laptop home, he unplugs the ethernet cable from the desktop and plugs it into the laptop. Even after power cycling both the laptop and the modem, it still won't pick up an IP address
It maybe that there is a problem with his home dhcp service.
Maybe it recorded a "bad address" for the host and now can't serve it.

If you have a DSL/cable router at hand, or if you can create a separate wired LAN with its own DHCP, which has a dhcp service, you could try to reproduce the issue with that. If you can't, then the suspicion is really that something does not work on that user's home dhcp. Maybe he can try to set a static dhcp configuration for his wired NIC on his home dhcp.

Running a network capture tool (netmon, wireshark) on his computer to capture the traffic on UDP 67 and 68 (DHCP ports) while the user runs [ipconfig /release "Local Area Connection"] and then [ipconfig /renew "Local Area Connection"] may give you some more details about what is going on with this user's laptop when he is at home. Note that you may need to adapt the name "Local Area Connection" for it to match the actual name for the Wired NIC.
Leon FesterSenior Solutions Architect
Commented:
It's very possible that this modem at home is setup with MAC filtering, with only his desktop assigned a reservation. Can he get an IP address from his modem on any other device e.g. a smartphone?

Maybe he should bring in his modem, so that you can test if another one of your work machines can get an IP address from his modem.

Author

Commented:
user is going to get a wireless router rather than have someone (me) come take a look at the modem again

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial