We help IT Professionals succeed at work.
Get Started

Unable to access destination table in SqlBulkCopy c#

officedog
officedog asked
on
6,783 Views
Last Modified: 2012-05-11
when attempting to use SqlBulkCopy with c#, I am getting the following error;

'Unable to access destination table'

I have googled various documents that refer to using the table/schema name are set as appropriate and have tried the following options;

Tablename
Schema.Tablename
[Schema].Tablename
[Schema].[Tablename]
Schema.[TableName]

All with the same results.

The user I am logging on with has limited rights, but does have Insert allowed for the table. Although it may be something to do with permissions, the message is not very helpful.

Any pointers as a little stuck.

Thanks
Comment
Watch Question
Software Engineer
CERTIFIED EXPERT
Top Expert 2011
Commented:
This problem has been solved!
Unlock 1 Answer and 5 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE