System Attendant Mailbox missing

newgentechnologies
newgentechnologies used Ask the Experts™
on

We have an Exchange 2007 server (Version 8.3 Build 83.6) On a Server 2003 x64 Enterprise server.

We have multiple databases but the primary one (or first one made on the server) became corrupted and Microsoft assisted us in moving the users to a new Database and the old one was decommissioned.
However now the system attendant mailbox does not appear in the list of mailboxes (when a get-mailboxstatistics cmd is run through the Exchange PowerShell).
Issues:
The GAL is not publishing to the OAB (can see new entries in OWA but not in Outlook cached mode)
We get errors trying to move mailboxes:
  <Result IsWarning="False" ErrorCode="-1056749262">Error occurred in the step: Opening source mailbox. Failed to open mailbox with error: ClassFactory cannot supply requested class</Result>
We get errors in the event viewer:
Event Type:      Error
Event Source:      MSExchange System Attendant Mailbox
Event Category:      General
Event ID:      4001
Date:            5/17/2011
Time:            10:13:25 AM
User:            N/A
Computer:      EXCHSVR
Description:
A transient failure has occurred. The problem may resolve itself in awhile. The service will retry in 56 seconds. Diagnostic information:
Cannot open mailbox /o=ORGANIZATION /ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EXCHSVR/cn=Microsoft System Attendant.
Microsoft.Exchange.Data.Storage.ConnectionFailedTransientException: Cannot open mailbox /o=ORGANIZATION/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EXCHSVR/cn=Microsoft System Attendant.
AND:
Event Type:      Error
Event Source:      MSExchangeFBPublish
Event Category:      General
Event ID:      8213
Date:            5/17/2011
Time:            9:54:52 AM
User:            N/A
Computer:      EXCHSVR
Description:
The Microsoft Exchange System Attendant service failed to create session for virtual machine EXCHSVR. The error number is 0x80040111.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
AND:
Event Type:      Warning
Event Source:      MSExchangeSA
Event Category:      OAL Generator
Event ID:      9399
Date:            5/17/2011
Time:            10:09:52 AM
User:            N/A
Computer:      EXCHSVR
Description:
OALGen is configured to generate version 4 offline address book (OAB) files for OAB '/o=ORGANIZATION/cn=addrlists/cn=oabs/cn=Default Offline Address List' and publish the version 4 files to public folders, but there is no public folder server available. OAB version 4 will be generated, but will not be published to a public folder at this time.  Please ensure that a public folder server with a replica of the OAB system folder is online and mounted, or disable publishing OAB version 4 to public folders.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Event Type:      Error
Event Source:      MSExchangeSA
Event Category:      General
Event ID:      2035
Date:            5/17/2011
Time:            10:11:29 AM
User:            N/A
Computer:      EXCHSVR
Description:
The e-mail address description object in the Microsoft Exchange directory for the 'MS' address type on 'AMD64' machines is missing.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Thank you for your time
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
I know someone will ask:


System Attendant HomeDB (AD attribute)

CN=Admin,CN=InformationStore,CN=EXCHSVR,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=ORGANIZATION,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=DOMAIN,DC=com

Information Store Distinguished Name:

CN=InformationStore,CN=EXCHSVR,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=ORGANIZATION,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=DOMAIN,DC=com

Commented:

1. Usually all you need to do is restart  the SA service and it should recreate the SA MB.
2. check out this article http://support.microsoft.com/kb/285116  as well as http://technet.microsoft.com/en-us/library/dd535374(EXCHG.80).aspx and http://technet.microsoft.com/en-us/library/bb217922(EXCHG.80).aspx

3. If that doesn't do it, have you already tried rebooting the server?  Default action is if missing it will be created, however I have seen situations where a second reboot is needed to get it recreated

Author

Commented:
Hi Lucid,

The Information Store is running, so I don't believe the first article is relevant. I had referenced the second article The System Attendant homeMDB attribute is missing and the HomeDB attribute of the System Attendant Mailbox does match the distinguished name of an existing storage group.

Looking into the third article now, Thanks.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
thanks for the udpate and let me know how things progress
Ok,

So the System Attendant Mailbox was missing from the server. The First Storage Group "First Administrative Database" was deleted without having the SA mailbox migrated.

If you happen to have this issue this is how it was resolved on a 2003 x64 server running Exch 2007 SP3 (Server has Client Access/Mailbox/Hub/Transport roles)

1) Dismount all Databases (Except public folders)
2) Rename the folders they're in (c:\exch\admin.edb --> c:\exch1\admin.edb) do this for all dismounted database paths excpet public folders
2) In ADSIEDIT set the HomeMDB value for System Attendant Mailbox to <not set>  (delete current, hit apply, close warning, click ok)
3) Create two new storage groups and mail databases
4) Restart the System Attendant Service
5) Create a new user on the first of the two new mail databases you created
6) Move the user to the second of two new mail databases you created
7) Verify the system attendant mailbox exists on one of the two new databases
8) Revert to the folder names from before  ( c:\exch1\admin.edb --> c:\exch\admin.edb)
8) Remount the existing databases

If you want to remove the storage groups created during this process you will need to migrate the system attendant properly.

Author

Commented:
No one came up with a solution
DanNetwork Engineer

Commented:
I have the same problem, running exchange 2013 with latest build.  I did NOT delete anything, I just started getting this error message out of the blue today.
Any ideas who to resolve it?

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial