Exchange 2010 SP1 DAG on Hyper -V Best practice analyzer conflicting information

Gerhard_W
Gerhard_W used Ask the Experts™
on
Per  http://technet.microsoft.com/en-us/library/aa996719.aspx, and related discussions you can deploy Exchange SP1 mailbox role with DAG on VM residing on a HA cluster node, as long as the Exchange VM does not participate in the failover cluster, but is configured as a standalone VM on that host.

When running the "Best Practice Analyzer" on such a configuration it complains about an unsupported VM configuration - Clustering. Based on the help information for the BPA it tests for "cluster service started" and "Model Key = VM" and then decides to complain.

Looks like the BPA is wrong and produces false information.

Does anybody have information about this apparent conflict?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Mohamed ElManakhlyInfrastructure Team Leader
Commented:
the scenario for DAG members on virtual machines is supported as long as the VMs them selfs are not in a Clustered scenario that might lead sometimes to automatic failover of the DAG members ..

Author

Commented:
So it looks indeed Microsoft forgot to update the BPA for Exchange 2010 SP1. Which basically makes the BPA useless as one cannot trust the results.
Top Expert 2011
Commented:
Hi,

It is right there are some things not right in the BPA.

Another thing is Microsoft updated there information about Dag members and a Hyper-V clustered scenario, they support it now.

Read here: http://eightwone.com/2011/05/14/exchange-2010-sp1-live-migration-supported/ also some other updates on exchange 2010 sp1 and virtualization.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial