Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Deleted Items retention not working as expected in Exchange 2010 SP1

Avatar of osiexchange
osiexchange asked on
Exchange
5 Comments1 Solution877 ViewsLast Modified:
I am not a believer in the Deleted Items Retention feature. I have the setting configured for 1 day on the maiilbox databases. On the General tab of the Properties of the mailbox database, the setting under Deletion Settings which reads "Keep deleted items for (days): is set to 1. Yet, when Iook at some users mailboxes, I see messages in the Recover Deleted Items folder going back almost two weeks. I am opening the users mailbox on my workstation by creating a profile in my Outlook. I open the mailbox, highlight the Deleted Items bin and then select Folders > then Recover Deleted Items. I am looking at the Deleted On date. I see messages deleted over 10 days ago. They should be flushed when maintenance runs at night. I know maintenance is running because disconnected mailboxes are disappearing after the days I have set but I don't understand why the deleted items are hanging around. Is there something else I need to set or check?
ASKER CERTIFIED SOLUTION
Avatar of osiexchange
osiexchange

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 5 Comments.
See Answers