Avatar of KenshiroM
 asked on

How to stop my SBS 2003 from sending Spam.

Hi all, This is my setup: ISP Modem - Router - SBS 2003. Problem: IP was blacklisted due to large ammount of Spam sent. I used the following article : https://support.microsoft.com/kb/886208 , cleaned the machines using Malware Bytes. However when i restart the SMTP Service, it restarts sending SPAM ( Few Postmaster@*mydomain*.com and mostly the sender is "Best Entertainment" sent with varied email addresses). When i untick Anonymous Access in the Default Smtp Virtual Server the spamming sops.So I eventually left it for a while so that at least the users could send emails without the mail server sending spam, obviously as a temp fix, so not to get blacklisted.

Your advice is highly appreciated.

Thanks .    

Avatar of undefined
Last Comment
Justin Durrant

8/22/2022 - Mon

Best practices is to have anon unticked or if it is ticked to only allow specific computers to use it.  You basically had an open relay.
Justin Durrant

View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.

Thanks for your quick replies.

When I untick Anonymous access, the server denies access to incoming mail, If it is ticked and only allow specific computers to use it , wouldn't it still deny access to incoming mails? Also, i used MXTOOLBOX and entered the following command : smtp: *Mail Server IP Address* and it gave me the following results:

1. OK - *Mail Server IP Address* resolves to *FQDN*
2. Warning - Reverse DNS does not match SMTP Banner
3. 0 seconds - Good on Connection time
4. Not an open relay.
5. 6.381 seconds - Warning on Transaction time

When i tried the telnet command in the Command Prompt : telnet - set localecho - open *Mail Server IP Address* the result was: Connecting To *Mail Server IP Address*...Could not open connection to the host, on port 25: Connect Failed

Any thoughts?
Justin Durrant

DO NOT untick anon.. LOL. then no one can email you, as you saw.

Your help has saved me hundreds of hours of internet surfing.