We help IT Professionals succeed at work.

Eliminate password prompts in Outlook 2010 with multiple Exchange accounts

Medium Priority
6,212 Views
Last Modified: 2012-06-27
I realize this is a known issue and there are lots of posts about it here and on the net. This is a slightly different take and am hoping to find a work around while waiting for Microsoft to fix this glaring bug.

Background:
Outlook 2010 (finally) allows you to open multiple Exchange accounts. The (documented)problem is that Outlook can ONLY remember the credentials of the last Exchange account that logged on. Soooo, if you have, say, 3 Exchange mailboxes that you use, you'll be prompted for credentials on 2 of the 3 mailboxes EVERYTIME you start Outlook. Very annoying - imagine if you had 7 or 8 mailboxes (as some of my clients do). That makes this wonderful new feature utterly useless.

Attempted workaround:
I tried to fix this by granting the main Exchange account (the first one setup and the default reply account) Full Access permissions on the other 2 mailboxes. Worked great! No prompts for passwords.

HOWEVER,
Whenever you try and send an email using one of the other accounts, the mail gets returned saying you are not allowed to send on behalf of the other user. Kinda makes sense from the credential point of view. I tried to no avail to give send as permissions on the other mailboxes, but the only thing that worked was to remove the full access permissions and go back to the multiple password prompts.

Any ideas on how to workaround this? It's a big problem for several of my clients. Also, anyone know of a way to get the attention of some uppity-ups at Microsoft's Outlook group to let them know what a huge problem this is?

Thanks to all!
Comment
Watch Question

use the email address of the login, say username@domain.com instead of domain\username in the login prompt.  Fixed it for me.
Sal SoricePresident

Author

Commented:
artisancomputer msm:

Not sure what you mean - need much more detail. Did you set Full Access permissions? Did you set Send As permissions? Are you using multiple Exchange mailboxes under one set of credentials? Please be much more specific. Thanks.
Commented:
What version of exchange are you running?

On exchange 2010 (assuming 2010 as you have the latest outlook) you should be able to simply fire up the EMC, navigate to Recipient Config -> Mailbox. Right click on the user and select Manage Full Access and then add the user(s) and then do the same for Manage Send As Permission.

You will likely need to log off then on again for it to take effect. It may also take a while for the change to be recognised depending on the size of the domain.

That's all i have done and i have 3 accounts in my outlook profile and i have no issues sending "From" the secondary and tertiary accounts.

Sal SoricePresident

Author

Commented:
Share-IT:

Using Exchange 2007 - not sure if that matters. I thought I had logged the user off/on after the changes but I'll try it again. Samll domain - only 8 users.

Will test again and advise.
scion111:

I mean when it prompts you for the credentials for the main account, instead of putting them in the form of domain\username, enter them in the form of an email address, username@domain.com.

Sal SoricePresident

Author

Commented:
artisiancomputer msm:
Sorry, your approach did not help my situation.

To any and all that see this post:
What "seems" to work for my situation:

1. Give the primary user (the one that belongs to the user who logs onto the PC and is the default Exchange account in Outlook) both Full Access and Manage permissions using Exchange Management Console on the other Exhchange mailboxes that you want to open in Outlook.

2. Log onto the PC and delete any .OST files that exist.

3. Logoff/logon and restart the PC a few times (not sure how many it took). I also did a few "gpupdate /force" commands on the PC. This step is a bit quirky, or at least it was for me.

EVENTUALLY, I was able to logon to the PC as the primary user and was able to send using the other email accounts. The only WEIRD thing I am encountering is that Outlook is prompting for the username/password of the primary account (even though it's already logged onto the domain).

This is a truly goofy way to get it to work, but I guess we'll have to muddle through until Microsoft realizes what a HUGE hassle this is. I'm not going to even bill my client for all the time its taken me to fiddle with all these "workarounds" - I can't justify it.

Plesae let me know if this approach helps anyone else - or, better yet - if anyone knows of a patch to fix it for real!!!
Sal SoricePresident

Author

Commented:
Sorry - one clarification.
In Step 1 above I said to give "both Full Access and Manage permissions" when I should have said Full Access and Send As permissions (as stated in my original question).

Share-IT:
Sorry, forgot to mention that the logon/logoffs did not help. It seems like deleting the OSTs did contribute to getting the workaround to take.
On the two mailboxes grant full access permission to the main account, also enable your main account to have Send-As rights for the other two accounts.  If you have "send on behalf of" permission set somewhere then disable it.  All you need is these two rights: Full Access & Send As.

BE AWARE THAT THIS CHANGE MAY TAKE UP TO TWO HOURS TO TAKE EFFECT.  Often times people will try this and think it doesn't work because it doesn't work right away.

Give this a try and see if it fixes your problem.
Another solution offered.
Sal SoricePresident

Author

Commented:
Sorry for the delay in responding. Although both Share-IT and artisancomputer_msm basically confirmed what I had already discovered and tried I'm splitting the points to say thanks for helping! While my client now says (after about 2 days) that the password prompts are gone I now have a strange problem in that when he send from one of the secondary accounts Outlook hangs and he can't get it to send the message - even after restarting Outlook/rebooting, etc. The message gets saved in drafts and can be successfully sent via Outlook Web Access. Hmmmm.... Oh, well, back to work...