Epson Advance Printer Driver - Failed to Install Port Handler Service

slightlyoff
slightlyoff used Ask the Experts™
on
I'm trying to install the Advance Printer Driver for a receipt printer.  A few days ago, this printer was installed and working fine.  I received a call saying it wasn't working anymore so I came in.  After messing with it for awhile, I decided to uninstall and reinstall.  The uninstall went fine.  The reinstall, not so much.  For some reason, the installation gets almost all the way complete, then pops up the error:
 
Failed to Install Port Handler Service.  Error Code = 1073
Setup will delete the current installation.

The current service already exist

I'm kind of stuck.  Ok, actually, I'm really stuck...  I've tried running registry cleaner to see if that would help.  I've restarted the computer after uninstalling everyting related to Epson.  The computer here didn't have a System Restore point, so I can't  go back to the time when this thing was working correctly.

Any ideas?  Thanks for your help!!!

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
My guess we need to get this service out.

You did not say what service pack, I am assuming win7 os since it is in that zone?  It might be pain full. I would suggest to get an application called autoruns it is from sysinternals which is Microsoft.
http://technet.microsoft.com/en-us/sysinternals/bb963902
It might give you an idea of what is loading for the stuck service. it gives you all files that load on boot / startup including manufacture.  Caution it will delete, disable any thing  that automatically starts with the machine so back up registry and use caution.  Even to the point windows wont boot at all.  Maybe this will give us some direction.  
Commented:
I think the problem lies on the port of the printer. During installation, a port for the printer will be created and the installation crashes because its already there.
You could always delete it and try re installing the driver.

I have a client with 12 points of sales. All of them have epson receipt printer which utilizes the advance printer driver. During the day some of the POSs will stop printing for some unknown reason..
The solution i came so far is to restart windows print spooler and everything will come back to normal.

I spoke with epson helpdesk but they couldn't help me.. Doesn't matter which operating system i am using (winxp pro, winxp embeded or win7).

Iam frustrated to the point im thinking not to use epson receipt printer again till epson give me a stable, working, solution..

Will keep you updated in case i find a solution mate.
Good luck
Ok...
Uninstall the Epson Drivers completely.
Then Follow this instructions.
http://posworld.us/downloads/epson/standard.txt
(Driver File: http://www.posworld.us/downloads/epson/standard.exe)

Hope this helps.
Build an E-Commerce Site with Angular 5

Learn how to build an E-Commerce site with Angular 5, a JavaScript framework used by developers to build web, desktop, and mobile applications.

Commented:
launch services.msc and check the name of the service...then launch command prompt in elevated mode and then type " sc delete servicename " withoutquotes.


Restart the computer and then try to install the program.


Ded9

Author

Commented:
Thanks for the help!  Sorry for the delay, I posted this on my last day of work before vacation, and didn't get back to it.

I really appreciate the help.  I'm splitting the pionts, because I got this to work before the first response came in, but I pretty much did what you all suggested.

Epson doesn't do a good job of removing ports and services when it uninstalls (at least when it comes to the APD.)  But after deleting services and freeing ports, it's all good.

Thanks again for responding!!!
sir how do I know what servicename does my printer have

sc delete "servicename"?

i tried EPSON, EPSON TM U-220

none of them works
please help

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial