Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3807
  • Last Modified:

"Cannot Connect to Configuration Database" SharePoint 2010

I have been trying to successfully install SharePoint 2010 on a Windows Server 2008 R2 (HOUSE-2K10MOSS01) and SQL 2008 R2 on a separate Windows Server 2008 R2 (WAMR-2K08SQL01). I've tried multiple times installing SharePoint 2010 multiple times but I keep running into the same problem. Here's the order of operations:

1) I configured SQL on the first server, configured the firewall for the appropriate 1443 port on both servers and installed SharePoint 2010 on the MOSSServer. Initially, I was getting errors with the SharePoint configuration wizard when I tried to configure portion where the SQL Server \ database and user account to configure the SQL database. Initially, I was using just the computer name (WAMR-2K08SQL01), but it never completed successfully. I found I could get it to move forward and identified correctly  if I used the fully qualified domain and dns name (WAMR-2K08SQL01.domain."com".


2) Once it would complete and I got a successful completion message I'd run the command line "iisreset" then click "Finish" where the Central Administration then tries to open. Even though everything ran aand completes successfully the Central administration page never connects and instead simply says "Cannot connect to configuration database".

3) After trying this several times I decided to have a DNS entry created to help the identification of the SQL server . The new DNS entry identifies the machine by it's fully qualified DNS name (WAMR-MOSSSQL.Domain..."com")

4) I have then tried to re-install using the SharePoint configuration wizard. I've tried other names, but again it will only connect if I use the fully qualified DNS name. So when I start the configuration wizard,  I get an error, though it completed successfully previously. I get an error message and a log file (I've attached below). The error is "Failed to detect if this server is joined to a server farm...." If I click OK, and press "Next" again, it does NOT give me the error message and instead finds the SQL server configuration and again will complete successfully.

5) I then restart IIS, click finish and again I get the "Cannot connect to the configuration database".

6) I then have checked Event Viewer to see if I can get any more information. I found the following error: "Cannot connect to SQL Server "WAMR-2K08SQL01\HOUSEMOSSSQL" not found. Additional error information from SQL Server is included below. Timeout Expired. The timeout period elapsed prior to completion of the operation or the server is not responding."

I've tried different commands to change the timeout period but I'm not sure if I have the correct command since it never completes successfully. After over a week of trying different options, and everything I can think of I'm now looking for help to get this completed so I can finaly get passed these errors and begin configuring SharePoint Central Administration and begin installing my SharePoint application for my office.

Any help would be very much appreciated. Thanks.

SharePoint Wizard 1 SharePoint Wizard 2 SharePoint Wizard 3 SharePoint Wizard 4 SharePoint Wizard 5 SharePoint Wizard 6 SharePoint Wizard 7 SharePoint Wizard 8 SharePoint Wizard 9 SharePoint Wizard 10
PSCDiagnostics-7-5-2011-19-12-58.log
0
theoclark
Asked:
theoclark
  • 2
  • 2
1 Solution
 
amolghanwatCommented:
try this to test and confirm connectivity.

Open notepad. Save the file with the name "testConnection.udl"
The ".uld" part is important as we are going to test it using this connection file.

Double click on that file and it should open "Data Link Properties" window

 Data Link Properties Window
On the next tab - "Connection", enter your SQL instance name and then try to fetch database from the drop down on the same screen.

If it fails, then there is a problem with either
Network
Firewall
SQL service

If the data link window returned the database names, then the account with you are running the PSConfig wizard does not have "DBCreator" and "SecurityAdmin" rights in SQL.
0
 
amolghanwatCommented:
Small typo in the above command.
File extension is ".UDL" and not ".ULD".

Also, in the data link properties window, make sure you select connector for SQL Server as shown in the screenshot.
0
 
theoclarkAuthor Commented:
Amolghanwat thanks for you help. When I do what you instructed me, here is what happens.

First I created the .UDL file as you instructed, saved it to my documents folder. I open the file, selected the Microsoft OLE DB Provider for SQL Server. I then when to connection, and I simply clicked the drow down menu where I can select the SQL Server name and database. One note, the Server and Database name are not fully qualified with the domain extension on it.



 Database
I then type in the username of the SharePoint Administrator, that I also used in setting up SQL and added as a SQL Administrator during that setup. After entering that  information, and I know I have it correct because I'm logged into the computer with the MOSS Admin Account using the same account and password. When I go to select the database name I get the following 2 errors.

 Login Failed Cannot Retrieve

If I simply click the "Use Windows NT Integrated security." which if I understand it correctly is using the account of the locally logged in computer which is the same MOSSAdmin account, I'm able to select the database from the drop down list.

 NT Retrieve
Next  if I test the link using Windows NT, it connects successfully.

NT Success
I imagine I need to look at my permissions but before I do that, am I correct in that using NT it's essentially connecting as my local user, in this case the MOSS Admin. How could that be or am I wrong in my thinking. Let me know your thoughts and what I should do next. Thanks.

           
0
 
rick_rsCommented:
Hi,
Firstly, go into your Database Server and opne the configuration Manager of the SQL Server Installed, I believe you are using a named instanc eof SQL Server and not the default one. Create and Alias name for the SQL Server and grant the MOSS Admin Account DB Creator and DB Owner permissions to SQL Server.
Then, go to your Application server and ping the new ALias name (you just created) using command Prompt  type : PING <Alias Name>.
If it returns back a response very good Proceed to step 2.
If not, uninstall SQL server from the DB server and re-install it but this time use the default Instance name and again create an Alias name and ping it from the App Server.Then go to Step 3
Step 2: Using stsadm in the app server,change the name of the SQL server SharePoint is pointing to usig this command stsadm.exe -o setconfigdb -databaseserver ServerName -farmuser MyUserName – farmpassword MyPassword. Then run the Farm Cinfiguration Wizard.
-Step 3:If you are ok till here, then you are ready to perform the next step.delete the central admin website and run the farm configuration wizard.
0
 
theoclarkAuthor Commented:
Their information was helpful for me to find out what really the problem.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now