Avatar of Hello-Everyone
Hello-Everyone asked on

remote.companyname.com only accessible from outside the network, internally, can not access

Hi all,

I have just setup SBS2011.  It appears I am experiencing an odd behaviour.

I can only access https://remote.companyname.com from OUTSIDE the company network OR directly from the SBS2011 server's Internet Explorer.  If I try to access from any of the client's PC, it will not work.  It times out on IE.

I have been suggested already to try PING remote.companyname.com from a client PC and it returned external IP address, instead of the internal server address.

This might also explain why I could not do http://connect.  It also timed out.  In fact, launch.exe (on USB Flash drive) didn't even work.

I believe I need to fix the DNS on the SBS2011 server.  Can anyone suggest some steps to fix it?

Many thanks!

Paul
SBSWindows Server 2008Networking

Avatar of undefined
Last Comment
Hello-Everyone

8/22/2022 - Mon
Andrew Oakeley

I thought the SBS wizards should have created this for you... but if not...

create a "Primary forward lookup zone" in DNS managementwith the full name remote.company.com
create a A record within that zone with no host with the IP of the server. This image should be enough to get you going

once you have done that ipconfig /flushdns on the workstation and it should now resolve to the internal IP. Make sure the workstation only has the SBS server as its DNS server

 DNS
Andrew Oakeley

If HTTP://connect is also not working it sounds like your workstation might be pointing to the ISP DNS Server. Please make sure your workstations are only using the SBS Server for DNS

Maybe run the "Fix My Network" wizard. That should sort all this out for you.
ASKER
Hello-Everyone

Sorry to be a pain but do you mind telling me how to get to the DNS Management screen from the SBS Console?
Your help has saved me hundreds of hours of internet surfing.
fblack61
ASKER
Hello-Everyone

Re: Run Fix My Wiz - Huh hahahaha.... easy for you to say.  I just met SBS2011 this morning.  The last server was SBS2003.
Andrew Oakeley

DNS console you can get to from Administrative Tools

Fix my network is in the SBS Console. Network -> Connectivity Tab
ASKER
Hello-Everyone

Ok... running fix my network now...
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
Hello-Everyone

It came back with 2 issues:

"An External DHCP server was found"

and

"DHCP service stopped"

I have checked both and trying to fix it.
Andrew Oakeley

Disable the DHCP server on your router and re-run the Fix My Network wizard.

The windows DHCP server will not be able to start with there being another DHCP server. And if the workstations are getting DHCP from the router this will account for your DNS issues....
Andrew Oakeley

on the billion router (if I recall correctly) go into "advanced configuration" -> LAN - DHCP Server or smoething like that....
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
ASKER
Hello-Everyone

When I updated the router firmware, it reactivated itself as DHCP server and disabled SBS2011 DHCP.  Fixed that and restarted the DHCP server on SBS2011 but my issues are still the same.

- Ping from client to remote.companyname.com returns external IP (even after I restarted the PC)
- I still can not visit remote.companyname.com from client PCs

Just ran fix my network wiz again.  The result is:

"Could not configure the router" (It says to open ports 80, 443, 987, etc.,) and

"DHCP is not configured correctly"

And the crazy part is, I have test user setup on test client PC and it stopped sending and receiving emails.  Doh!!
Andrew Oakeley

reboot a workstation
post results of "ipconfig /all" here
ASKER
Hello-Everyone

After rebooting the SBS2011 and workstation.  The result of ipconfig /all from the workstation is:

IP Address 192.168.0.251
Subnet 255.255.255.0
Default Gateway 192.168.0.1
DHCP Server 192.168.0.1
DNS Servers 192.168.0.1

Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Andrew Oakeley

looks like the workstation is still getting DHCP from the router (192.168.0.1).

Double check the router DHCP is disabled
ASKER CERTIFIED SOLUTION
Andrew Oakeley

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
Hello-Everyone

I just checked again and it 100% says, "The DHCP Server Mode = disabled"

I have no idea how this is happening!  Could it be something that went wrong at DNS provider end?  

I am getting pretty stuffed so I might have to head home.  I will be happy to answer your postings and test them all out tomorrow.
ASKER
Hello-Everyone

I am looking at the DHCP Console but I don't know what I am looking for to confirm that it is working.  It lists IPv4 and IPv6 with green tick next to them. They both appear under my companyname.local.  Is that right?
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Andrew Oakeley

That all sounds good  (IPv4 and IPv6 with green tick next to them)
- reboot the router
- make sure there is only one workstation plugged into it, unplug everything else from the router
- confirm that the workstation DOES NOT get an IP Address

I suspect in the morning with a fresh set of eyes it will come clear to you. It really is not this hard.
This is not a DNS Provider issue, it is an issue with another DHCP serve on your LAN. Maybe try factory reset the router and start again. You mentioned earlier that you did a firmware upgrade on it, if you did not factory reset it this could have caused an issue?
Cliff Galiher

Or...from the problems with RWW on the last question, the issues I. This question, and the fact that your router us clearly not designed for businesses (a huge security concern in my book) ... Just replace the router with one more functional, less schizophrenic, and more trustworthy.

-Cliff
Andrew Oakeley

> less schizophrenic
LOL - love your style cliff :)
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
David Johnson, CD

a work around is to add your sbs servers ip address in the dns slot of the client machines. Like so
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
David Johnson, CD

Those startup wizards are not just there for eye candy.. it should have been staring you in the face.. but you elected to go to the advanced screen i'll bet
Andrew Oakeley

:)
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
ASKER
Hello-Everyone

ve3ofa,

It's not that I was impatient, I under estimated that wizards ability. I had Internet access so I thought I didn't need to run it.
David Johnson, CD

I think it is number 1 on the list of things to do.. sbs is a complicated beast with many interlocking components that the wizards make setup a breeze compared to setting up the same components on a server2008 system.
ASKER
Hello-Everyone

Yes, I am liking this wizard thing. I coming from SBS 2003 so...
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Cliff Galiher

All your base are belong to us
ASKER
Hello-Everyone

I'm just closing this off and encourage anyone who might find themselves in the same boat as me...

Lesson here is, even if your internet is working, run "Connect to Internet Wizard" when installing SBS!