Link to home
Create AccountLog in
Avatar of ICresswell
ICresswell

asked on

CSM 4.1 - Flexconfig (Syntax errors detected - Failed to setup Velocity Engine to validate syntax)

Hi,

I am trying to build a simple flexconfig to create route map statements that apply to NAT rules. When I try to create any basic flexconfig, I get the following error msg:

Syntax errors detected

Failed to setup Velocity Engine to validate syntax

Please correct errors.

I also tried cloning an existing example "IOS_enable_SSL", rename and recieved the same error.

What is the Velocity Engine and how can I verify that this component is working correctly?
 
Regards
Ian
Avatar of Steve Jennings
Steve Jennings

Is this a new install? Have you created any flexconfigs successfully?

I'd be on the phone with Cisco or opening a TAC case. I got a couple of odd errors trying to fix a flexconfig I created from scratch and it turn out I was missing part of the install.

The velocity template engine is an open source product from Apache. It's java based so you may simply have a java version problem. But if things have been working up to now, that probably isn't the issue.

Does the install log show any java warnings?

Good luck
SteveJ
ASKER CERTIFIED SOLUTION
Avatar of ICresswell
ICresswell

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of ICresswell

ASKER

It was an authentication issue on the server running CSM, I had to run th eprg as local admin.