Avatar of SpringMVC
SpringMVC asked on

Hard drive problem, current status(Auto-detecting SATA3 freezes bios)

Hi.
About a week ago while I was working on my computer, it suddenly hanged ( All programms didn't respond ).
I decided to restart it manually(not through windows, but by pressing a button on my computer).
From this moment Windows7 stopped loading...
I managed to load with Kubuntu live CD and it showed me, that my C: drive is marked as in use(or its NTFS is marked as in use). There were two suggestions: load Windows and properly shut down it, use something like force mount.
Well, first option, obviously, wasn't for me, so I made "force mount". After that Kubuntu started to show me: "NTFS is in inconsistent state" something like that. And I still had no access to my files on that drive.
I tried to load my Windows7 one more time, but with no success. One thing I have marked, that now Windows "loads/goes" a little bit further till Windows logo and stops there.
I tried to "repair" my C drive with Windows7 disk, but again with no success. I tried to run "chkdisk C: /f", but system printed out something like "No direct access to disk".
I decided to install Windows7 to another my hard drive(IDE, not SATA, previous drive, by the way, was SATA) and to try to access my files from that installed windows.
But another problem occured: now with my SATA drive connected, even BIOS hangs on message Auto-detected SATA3(my hard drive is connected to this port).
Any ideas, how I can safe my hard drive or at least files on it?
Any help would be highly appreciated!
P.S sorry for my english
Components

Avatar of undefined
Last Comment
Qlemo

8/22/2022 - Mon
John

I would try putting the bad drive in a carrier (inexpensive if you do not have one) and move the drive to another machine (not the machine above). Now see if you can read the bad drive in another machine.

If not, you may have lost your data. You can try recovery applications like SpinRite (grc.com), but (good as it is) there is no guaranty.   ... Thinkpads_User
ASKER
SpringMVC

Ok. Tomorrow I will try.
nobus

disconnect the ide drive -only sata drive
then boot from a live knoppix cd -and try to copy your fiiles to an external USB disk :
ftp://ftp.kernel.org/pub/dist/knoppix/KNOPPIX_V6.4.4CD-2011-01-30-EN.iso

if this does not work - then it loks like the "bad disk" interface is locking up your hardware
post results
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Dr. Klahn

There may be an interface conflict between the SATA drive and the system controller.  Not all systems are capable of handling higher speed SATA drives.  Check the offending drive and see if there is an option jumper or switch to lock it to SATA 1.0 mode.

From Wikipedia:

To prevent interoperability problems that could occur when next generation SATA drives are installed on motherboards with legacy standard SATA 1.5 Gbit/s motherboard host controllers, many manufacturers have made it easy to switch those newer drives to the previous standard's mode. For example, Seagate/Maxtor has added a user-accessible jumper-switch, known as the Force 150, to enable the drive to be switched between 1.5 Gbit/s and 3 Gbit/s operation. Western Digital uses a jumper setting called OPT1 Enabled to force 1.5 Gbit/s data transfer speed (OPT1 is enabled by putting the jumper on pins 5 & 6). Samsung drives can be switched to 1.5 Gbit/s mode using software that may be downloaded from the manufacturer's website. Upgrading a Samsung drive in this manner requires the temporary use of a SATA-2 (SATA 3.0 Gbit/s) controller while programming the drive.
ASKER
SpringMVC

Nobus, if I connect SATA drive(no matter only SATA drive or also IDE drive), even BIOS won't load. It will hang on "Auto-detecting SATA".
DrKlahn, This SATA drive worked fine on my computer a week ago, before this bad situation happened. So I don't believe, that some hardware/interface conflict occured out of nowhere.

By the way, yesterday I tried this SATA drive on another computer. Same thing...It hangs on "Auto-detecting SATA" and, moreover, it resets BIOS settings...
If I switch in BIOS, that it will "recognize" SATA not as IDE, but as AHCI(or something like that), BIOS loads successfully (no "Auto-detecting SATA"), but it doesn't see SATA drive(i.e after BIOS loads, and if I enter into it, it shows, that all SATA are "Not detected").
ASKER CERTIFIED SOLUTION
nobus

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Qlemo

This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.