Avatar of Supracom
Supracom
Flag for Netherlands asked on

Security: This file came from another computer and might be blocked to help protect this computer

One of our customers is running a Windows 2008 R2 standard server with Citrix XenApp 6 installed.
The are logging in with thinclients. Some users report the problem that they can't open files.

When I look at the file properties I see the following text:
Security: This file came from another computer and might be blocked to help protect this computer
And there is a button: Unblock.

I wan't to disable this security setting so that the users can normal open and read their documents.

Windows Server 2008

Avatar of undefined
Last Comment
Supracom

8/22/2022 - Mon
Darius Ghassem

Goto: User Configuration > Administrative Templates > Windows Components > Attachment Manager
Enable: Do not preserve zone information in file attachments
josika

You can set the following group policy setting:

User Configuration > Administrative Templates > Windows Components > Attachment Manager:

Set 'Do not preserve zone information in file attachments' to 'Enabled'

If it is just one file you want to unblock then go to the Properties of the file and click 'Unblock'.
josika

^ what dariusq said :)
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Supracom

ASKER
Damn, forget to tell :)
The option in the GP settings have I tried already. Doesn't work.
They still get an error while opening the files.

They work with Office 2010. And it is not just one file. It's a hard problem. strange thing is, when User1 create a .doc and send it by email to User2. User make some modifications in the file and send it back to User1. User1 get the error like i said above.
So their own documentents are marked as unsafe when they are modified by another user/computer.
josika

Hmm, did you have the user log out and back in or run 'gpupdate' after making the group policy change?
Supracom

ASKER
Yes is tell the user to log out and back in. Didn't work.
So I thought, I restart the server at night, then i'm sure that no one is still logged in. But no result after the restart!
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Darius Ghassem

Darius Ghassem

Supracom

ASKER
I'll try to add the servers (file server and AD server) in the trusted zone. I'll let you know if it works!
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Supracom

ASKER
Hmm, some bad news over here.

Adding the server to the trusted zone doesn't do the trick!
It's a mirakle!

I have tested some things out now. When they get an internal e-mail with a attachment, they can open it without an error.
When they get an e-mail from an external address, they get an error when the want to open the attachment. The only way to open this one, is save the attachment to the desktop and remove the security block.

I don't see the point where it is blocked. We manage arround the 100 networks for our customers and this is the only one who gets an error with their attachments.
Darius Ghassem

The only restriction that I know of is the one above. Are you sure GPO is applying properly?
ASKER CERTIFIED SOLUTION
Supracom

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Supracom

ASKER
I have find my one solution!
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.