Avatar of cbridgman
cbridgman
Flag for United States of America asked on

VMWare Guest Won't Connect to Internet / Wireless


A few days ago I posted the same question (without the wireless part) ... how do i get my vmware guest to connect to the internet. After a few false starts and help from folks here at experts exchange, I finally got my guest machine connected. What I did basically was to choose a single network adaptor (BRIDGED) and plug the host machine into my home uverse network via an ethernet cable. My host was communicating wirelessly with my home network and that apparently was the biggest problem. Once I connected with a cable, all the problems disappeared.

I am, however, back at square one. I am attempting to get connected to the internet on my guest machine while my host is wirelessly connected. It's not working. When I plug in it works but when I unplug and go wireless, it doesn't.

I've turned off firewalls on both sides, guest and host, to no avail.

The host is win 7 64 bit, the guest is win 2008 server 64 bit. UVERSE is my ISP. I don't have a static IP address.

Any ideas?
VMware

Avatar of undefined
Last Comment
cbridgman

8/22/2022 - Mon
EmpoweredBiz

are you using ESXi or VMware Workstation ?
cbridgman

ASKER
vmware workstation
benwes

Did you try NAT?
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
cbridgman

ASKER
I did. When I the host is wired, both NAT and BRIDGED appear to work. When wireless, neither one does the trick.
EmpoweredBiz

Go into the Virtual network editor and in there you can see which adapter vmware workstation is using for nat and bridge mode and adjust it there
John

Also, please take a look at this article that talks about adding wireless LAN service to Server 2008.

http://www.windows-noob.com/forums/index.php?/topic/445-how-to-enable-wireless-in-windows-server-2008/

I wonder if that has been an issue all along. ... Thinkpads_User
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
benwes

By wireless, you mean 802.11b/g/n, right? Is your wired router and wireless router the same device? Do both connections give you an IP address on the same subnet? I am wondering what is different about the wireless connection - is it an issue with the network or an issue with the adapter on the host machine.

When you bridge to the wireless adapter, do you get an IP address at all on the guest?
bgoering

Go into the virtual network editor and set vmnet0 to be bridged specifically to your wired adapter (instead of automatic)

Next pick an unused vmnet adapter, say vmnet2, and set that to be bridged specifically to your wireless adapter.

On your virtual machine edit the settings and for network choose custom and point to vmnet2.
cbridgman

ASKER
Sorry, we've been without power for over 24 hours now and have been unable to test any of these suggestions.

I am unsure, however, how to open the Virtual Network Editor ... I don't know how to get to that.

Also, Ive attached some screenshots of ipconfig results from both host and guest that may help you resolve my problem
VMWare-Internet-connect-Problem.docx
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
benwes

Try disabling the Hamachi network adapter.

I think it might be NATing or auto-bridging to that.

If that fixes it, in VMware workstation, go to edit -> Virtual Network Editor ->
VMnet0 should be the bridged network, change it from automatic to your wireless network adapter. Or maybe even better, try clicking "automatic settings" and see if you can remove the Hamachi adapter.

Then change the VM network settings to bridged.
John

In addition, did you try my link to enable wireless in Server 2008 itself? This is a server setting and not a VMware setting. .... Thinkpads_User
bgoering

I believe that VMware Workstation will pretty much always NAT to the wired adapter (or wherever the auto bridging takes it).

The only sure way to make the guest use the wireless adapter is to do as I suggested and take an unused vmnet (I recommended vmnet2) and force it to bridge to the wireless adapter while making vmnet0 always bridge to the wired adapter. That autobridging is the most confusing thing vmware could have done for their hosted products.

To find the virtual network editor, open the start menu and go to vmware - you should have an icon to launch it from there. In Workstation 7.x you can also get to it from the "edit" menu option.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
cbridgman

ASKER
I just disabled Hamachi and get same result (see attached screenshots). Also, I did enable wireless in Server 2008 as suggested. VMWare-Internet-connect-Problem.docx VMWare-Internet-connect-Problem.docx
John

For my own VMware Workstation and a dozen guests (but none server), the guests will connect to the internet using NAT or Bridged networking as supplied by VMware. I don't need custom adapters. But my guests are non-server and cbridgman's guests are all server so far as I know.

... Thinkpads_User
cbridgman

ASKER
Okay, here is what I did. Is this correct? I haven't tried it yet. screenshot of network setup
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
cbridgman

ASKER
You are correct thinkpads. My guests are server .... either server 2003 or server 2008. the one i'm having problems with right now is server 2008
chkdsk01

Go into Virtual network editor.  See pic1.

Then pick the wireless nic for "bridged to".  See pic2
pic1.JPG
pic2.JPG
John

OK, so now you want to select VMnet2 in the Virtual Machine settings (where you selected NAT/Bridged originally) but no other adapter - just VMnet 2 and then test.

It might be worthwhile to restart your machine first to ensure VMware has got the new adapter.

... Thinkpads_User
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
bgoering

That looks good on the network setup, now change the guest (in edit settings) to be custom network and select vmnet2.

You don't need to install the Wireless LAN on a 2008 VM, because no matter how the vm is ultimately getting to the network, it looks like a wired lan to the guest.
bgoering

In my experience it always gets the new adapter right away. You can look in the network adapters setting on the host and see if it shows up. But a restart never seems to actually hurt Windows :)
cbridgman

ASKER
Okay, here is what I did. I'm restarting the VM now. I'll let you know if this helped. vmware network adapter setting - vmnet2
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
cbridgman

ASKER
That made things worse result of custom network 1 result of custom network 2
bgoering

Wow are those from the guest or from the host? If from the guest, is the host connected Wirelessly?

Open the vmnet2 adapter on the host and make sure the vmware bridging protocol is installed.
cbridgman

ASKER
Those are from the guest. And yes, the host is connected wirelessly. that's how I'm talking to you.

How do I open the vmnet2 adapter? ... sorry, i'm a bit of a rookie with network stuff.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
bgoering

Are you on XP? Win7?
bgoering

I know this works because I have done it! Albeit not for a while.

http://pubs.vmware.com/ws7_ace26/wwhelp/wwhimpl/js/html/wwhelp.htm?context=ws_user&file=ws_net_configurations_bridged.html

"Bridged networking configures your virtual machine as a unique identity on the network, separate from and unrelated to its host. It makes the virtual machine visible to other computers on the network, and they can communicate directly with the virtual machine. Bridged networking works with both wired and wireless physical host network cards."

Take a look at that article, in particular the part where it talks about "Replicate physical network connection state" and the IP requirements.
John

@cbridgman  - We all have been through a lot of testing with you. I see up top you are using Windows 7 64-bit for a host (same as me - Windows 7 Pro 64-bit).

Another consideration (not completely off the wall) is to try a different wireless card. I had two different wireless NIC's in my retired T41 Thinkpad and two different wireless NIC's in my current T61p Thinkpad in order to get the reliability and signal quality I need for top performance overall. So it is a consideration, but one I have lived through. ... Thinkpads_User
Your help has saved me hundreds of hours of internet surfing.
fblack61
cbridgman

ASKER
I have a USB wireless adapter that I will try tomorrow to see if that changes anything and let you know.
cbridgman

ASKER
Thanks for everyone's help on this in the past. I've done just about everything I can think of and everything you have suggested and am still having problems, albeit, slightly different ones. Using 2 network adapters (NAT and Host-only) on the Virtual Machine, I can now ping the host from the guest and vice-versa. I can even ping google.com and yahoo.com from the guest. The problem that I am having now is that I can't open any sites in IE on the guest machine. When I try, I get the "Internet Explorer cannot display the web page" message. I can open local sites ... the guest is running an appserver (websphere) and I can open the websphere console in IE with HTTP://localhost:9060/console. I just can't browse outside.

I have tried every combination of network adapter settings and each presents slightly different results and problems. When I tried using a Bridged connection only, for example, I was then able to browse the internet freely but had no connectivity to my host machine.

Please see attached file for more information.

Any additional help will be greatly appreciated.

And thanks for hanging in there with me on this. I'm just not very strong when it comes to networking and some of the terminology goes over my head. VM-Connect-Problems.docx
ASKER CERTIFIED SOLUTION
bgoering

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
cbridgman

ASKER
I'm downloading the newer version now. Hopefully, that will solve some of these problems. Once I've upgraded, I'll let you know.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
cbridgman

ASKER
Happy Days! Version 7 of Workstation did the trick. I can browse the internet, I can see my host and my host can see my guest, and everything else appears to be working. I've been struggling with this for months. Thank you for your help.
cbridgman

ASKER
That's the simplest solution yet.

Thanks to all who helped with this