Out of Office - Server unavailable

Kenzii
Kenzii used Ask the Experts™
on
Hi All,
After a migration from sbs 2003 to sbs 2011 we are unable to open out of office. we get the following error:

Your automatic reply settings cannot be displayed becuase the server is currently unavailable. Try again later.

When trying to access from OWA we just get HTTP error like the page cannot be found.

The IIS looks to be configured correctly. A SSL certificate is installed and outlook anywhere works so I would guess this means that the Cert is correctly installed.

The webdirectories URL's are all correct. and I have followed this link all the way through.:
http://www.proexchange.be/blogs/exchange2007/archive/2009/07/14/your-out-of-office-settings-cannot-be-displayed-because-the-server-is-currently-unavailable-try-again-later.aspx

I honestly am at a complete loss as to what is wrong.

Can provide screenshots or additional info!
Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
can you ping autodiscover.yourdomain.com from one of the client computers?  or, do you have the srv records set up for autodiscover?

This article has some information regarding using a single cert and autodiscover - http://www.thirdtier.net/2009/02/setting-up-an-external-autodiscover-record-for-sbs-2008/

Commented:
Is your autodiscover record pointed correctly to your server IP?

Commented:
adding to my last comment.

Try an nslookup on autodiscover to verify if it resolves to your server IP

nslookup autodiscover.domain.com

Author

Commented:
Thanks for the replies
Tried a NSLookup and it says:
Unknown can't find autodiscover.blizzardutilities.com: non-existent domain

we dont use a SAN cert. only a single SSL certificate so i didnt expect the autodiscover to work to be honest.

I am testing internally so should this resolve to our server?

Author

Commented:
The link above seems to be more towards external autodiscover settings.

Our issue is internal and external.

when connecting to https://mail.<mydomain>.com/EWS/exchange it goes through without error or prompt for password internally

externally - i get page cannot be displayed no prompt for password or anything

Author

Commented:
In addition to my last note. I am prompted for a password when doing this from another machine in the domain, just not from the server itself.

External still does not work.

Author

Commented:
Sorry, external DOES work.

Author

Commented:
When trying to browse to https://localhost/autodiscover i'm prompted for a password but it wont accept the administrator details then displays the following page:

 Autodiscover error

Author

Commented:

Test-OutlookWebServices results:


RunspaceId : 67a67fa3-9b30-44fc-ae14-a41b9d654b15
Id         : 1019
Type       : Information
Message    : A valid Autodiscover service connection point was found. The Autodiscover URL on this object is https://ma
             il.<mydomain>.com/autodiscover/autodiscover.xml.

RunspaceId : 67a67fa3-9b30-44fc-ae14-a41b9d654b15
Id         : 1013
Type       : Error
Message    : When contacting https://mail.<mydomain>.com/autodiscover/autodiscover.xml received the error The re
             mote server returned an error: (500) Internal Server Error.

RunspaceId : 67a67fa3-9b30-44fc-ae14-a41b9d654b15
Id         : 1023
Type       : Error
Message    : The Autodiscover service couldn't be contacted.

RunspaceId : 67a67fa3-9b30-44fc-ae14-a41b9d654b15
Id         : 1104
Type       : Error
Message    : The certificate for the URL https://sbsserver.blizzard.local/autodiscover/autodiscover.xml is incorrect. F
             or SSL to work, the certificate needs to have a subject of sbsserver.blizzard.local, instead the subject f
             ound is mail.<mydomain>.com. Consider correcting service discovery, or installing a correct SSL cer
             tificate.

RunspaceId : 67a67fa3-9b30-44fc-ae14-a41b9d654b15
Id         : 1113
Type       : Error
Message    : When contacting https://SBSSERVER.blizzard.local:443/autodiscover/autodiscover.xml received the error The
             remote server returned an error: (500) Internal Server Error.

RunspaceId : 67a67fa3-9b30-44fc-ae14-a41b9d654b15
Id         : 1123
Type       : Error
Message    : The Autodiscover service couldn't be contacted.

RunspaceId : 67a67fa3-9b30-44fc-ae14-a41b9d654b15
Id         : 1024
Type       : Success
Message    : [EXCH] Successfully contacted the AS service at https://mail.<mydomain>.com/ews/exchange.asmx. The
             elapsed time was 301 milliseconds.

RunspaceId : 67a67fa3-9b30-44fc-ae14-a41b9d654b15
Id         : 1026
Type       : Success
Message    : [EXCH] Successfully contacted the UM service at https://mail.<mydomain>.com/ews/exchange.asmx. The
             elapsed time was 327 milliseconds.

RunspaceId : 67a67fa3-9b30-44fc-ae14-a41b9d654b15
Id         : 1124
Type       : Success
Message    : [Server] Successfully contacted the AS service at https://sbsserver.blizzard.local/EWS/Exchange.asmx. The
             elapsed time was 31 milliseconds.

RunspaceId : 67a67fa3-9b30-44fc-ae14-a41b9d654b15
Id         : 1126
Type       : Success
Message    : [Server] Successfully contacted the UM service at https://sbsserver.blizzard.local/EWS/Exchange.asmx. The
             elapsed time was 15 milliseconds.



[PS] C:\program files\microsoft\exchange server\v14\scripts>
If external works, do you have the autodiscover and srv records set up on internal dns - referring to my previous note?

Author

Commented:
thanks for the reply.
just setup a SRV that points to my external address. should this point internally?
Externally did not work. just tested.

Author

Commented:
Just changed to interally and tried and it didnt work.

Author

Commented:
changing the anonymous authenciation to enabled has made test-outlookwebservices connect through but we are still unable to get out of office to work.
keep the dns to point internally and give it a while, I have seen it not work and then for no reason would start working with no more configuration.  give it a while and see if it will start working.

Author

Commented:
thanks, so just to confirm whilst we wait. I have made a SRV record that points internally to the new sbs 2011 server on port 443.

I also (a few days ago) created a autodiscover a record and pointed that to my new sbs 2011 server.

Thanks

Author

Commented:
Also noticed,
when i'm on the OWA and i try to set automatic replies, i get prompted for login details > enter them and then get HTTP 400 bad request.

I'm sure there is something tied into all of this not working.
for example, internally if the ip address of your exchange server was 10.10.0.24 you would point the autodiscover record to 10.10.0.24.  have you tried running a ipconfig /flushdns to see if you are able to get the out of office to work after running that command?
could be, have you installed service pack 1 yet for exchange? sometimes that will fix the quirky issues with IIS

Author

Commented:
I believe that SBS 2011 comes with Exchange SP1, I think its coming to the point where i will need to reinstall the CAS.

Will i need to completely reconfigure exchange after that?

Author

Commented:
and RE your flush DNS request.

I have tried that already, Also, because i am not at the site I am VPN connecting throuhg to test locally and have outlook anywhere to test externally.

Thanks again for your help with this.
be careful reinstalling the CAS, that can really mess up exchange.  If I remember correctly the way I have done that in the past.  uninstall SP1, then IIS, then CAS and reinstall in IIS, CAS, and then SP1.  Be sure to have a solid backup of data and system state.

Author

Commented:
ok that will have to be a very last resort then.

Author

Commented:
Left the DNS to update over the weekend and unfortunately we are still having the same problems.

any other ideas? Ideally we dont want to reinstall CAS or IIS.

Thanks
thats all I can think of right now, next step would be to reinstall IIS and CAS, just make sure like I said above to have a good backup.  I would uninstall the cas role and iis, remove sp1, reinstall iis and cas and then reinstall sp1.  reinstalling sp1 at the end ensures that exchange will be working correctly after removing and reinstalling iis.  I can't find any documentation that doesn't say you need to reinstall exchange completely, but I can say that I have reinstalled iis and cas successfully when I was having trouble with iis.
Commented:
ok, issue was with the secure cert.
I added autodiscover.domainname.com to my external DNS and this provided a autodiscover cert error through outlook.
Which then prompted me to buy a UCC Cert to allow mail and autodiscover - this resolved my issue.
Thanks for all your help.

Author

Commented:
SRV record and my post RE cert resolved the issue.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial